4x4 question - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-02-2012, 09:19 AM Thread Starter
Powerstroke.org Fanatic
Jerry@tx's Avatar
Join Date: Nov 2011
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
4x4 question

Last night i was towing a trailer and had to put it on 4x4high on the beach, but when i left i couldn't take it outta 4x4. The tranny wouldn't shift into higher gears, my switch was on 2wd, i was driving 30 mph on 2k rpm. I stopped but it on rev and it would disengage. It finally disengage when i unhooked the trailer, and put it in rev. The car smelt like tranny fluid when i was stuck on 4x4 driving 30mph. Does anyone have this problem or know whats wrong?
Jerry@tx is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome