02 feels like torque converter not locking - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-11-2011, 01:37 AM
Member
 

Join Date: Dec 2009
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
02 feels like torque converter not locking

First off i will admit that i have absolutely no knowledge about transmissions

With that said i have an 02 powerstroke with about 190k on it and lately it feels like the torque converter is not locking. the truck shifts through all gears just doesnt seem to have the power it used to when accelerating especially when pulling a trailer and trying to accelerate from like 40 on. Sometimes if i get into the throttle hard my OD light flashes but thats rare. I havent had a chance to pull the code though

Now my question is would my best bet be to replace the torque converter and see where that gets me? ive heard the 6.0 torque converter is an upgrade from the stock one

Also if i can get the od light to flash where can i take it to get the code pulled

thanks for the help guys,
Brandon
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-13-2011, 04:14 AM
Compression Ignition Addict
 

Join Date: Dec 2006
Posts: 1,182
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
"doesn't seem to have the power". That is probably not the converter.
"Tc not locking". How have you determined that?
The 6.0 converter is not a replacement. It's a 7.3 front cover with a 6.0 bowl. It will have to come from a tc supplier. It's not any better, just lower stall. If you get it with the billet front cover , then it's better.
Reply With Quote Quick reply to this message
  #3  
Old 02-13-2011, 05:36 PM
Member
 

Join Date: Dec 2009
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hmm seems like i have bigger problems now... pulling a 24ft enclosed trailer today my truck decided to take a **** on me 100 miles away.

pulled it there without trouble. Noticed the o/d light was flashing and the check engine light came on for about 2 mins but was shifting fine but shut it off, worked and then when i started the truck no od light flashing or check engine light

on the way home i took off at a light and it took a while to shift 1st to second but second to third was fine. Went to go take off at the next light and went nowhere. felt like it was in neutral. i waited a second and it took off fine and i pulled into a parking lot and called triple A for a tow home

going into the trans shop tomorrow i guess. Sounded like something was rattling inside the tranny
Reply With Quote Quick reply to this message
  #4  
Old 03-23-2011, 05:14 AM
ps3 ps3 is offline
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what did your problem end up being? mine is doing a similar act.
Reply With Quote Quick reply to this message
  #5  
Old 03-23-2011, 05:25 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 2,865
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
subscribed...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:01 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors