1st -2nd gear shift error - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-27-2010, 01:02 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 1st -2nd gear shift error

I have an 01 7.3 w/ just under 96k miles. A couple of weeks ago it started shifting funny. From a start I have to get it up to about 3000 rpm and then let off to get it to shift. When it shifts it does so very hard, after that it runs fine untill I stop and start again. So I decided a filter and fluid change might be in order. I bought this truck used and after having the pan off I don't think the tranns had ever been serviced before, lots of material on the magnet. After the filter change and new fluid, no change in the shifting. I read a post about the shift lever an overdrive button problems. So I checked and sure enough the wires were cut, so I replaced the shift lever still no change. So after that I have the OD light flashing after a few minutes of driving. Pulled the codes and got the 1st -2nd gear shift error and a 2nd gear ratio error. I also have a Bully Dog Triple Dog programmer. I put the truck back to stock and still no change.
Am I looking at a rebuild or a new tranny?
Also could the Bully Dog be the problem, should I get rid of it?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-27-2010, 07:49 PM
Banned
 

Join Date: Oct 2007
Location: Northern Arizona
Posts: 332
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If it's any early 01, could be the diode on the direct drum. You will need to check for codes.
Reply With Quote Quick reply to this message
  #3  
Old 02-28-2010, 11:02 AM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It is an early 01, just pulled to codes again and got
0781 1-2 shift malfunction
0603 Intenal Control Module KAM error
Reply With Quote Quick reply to this message
  #4  
Old 02-28-2010, 11:05 AM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,762
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Rebuild, you said there was a lot of material on the magnet. If that is the case then it is most likely time for a rebuild.

When rebuilding do it right. Upgrade to a triple disc converter, up grade your clutch packs, upgrade your valve body, if you do this you should not have to worry about rebuilding the trans for the rest of the time you own the truck.
Reply With Quote Quick reply to this message
  #5  
Old 02-28-2010, 12:03 PM
Banned
 

Join Date: Oct 2007
Location: Northern Arizona
Posts: 332
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by The Welder View Post
It is an early 01, just pulled to codes again and got
0781 1-2 shift malfunction
0603 Intenal Control Module KAM error

It sounds like diode broke loose. The KAM error "keep alive memory" could be the tuner causing this.
Reply With Quote Quick reply to this message
  #6  
Old 02-28-2010, 12:31 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bigcountrysg View Post
Rebuild, you said there was a lot of material on the magnet. If that is the case then it is most likely time for a rebuild.

When rebuilding do it right. Upgrade to a triple disc converter, up grade your clutch packs, upgrade your valve body, if you do this you should not have to worry about rebuilding the trans for the rest of the time you own the truck.
Thats kinda what I thought, just looking for some other opinions
Got any recommendations for those parts.
Reply With Quote Quick reply to this message
  #7  
Old 02-28-2010, 02:02 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,762
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by The Welder View Post
Thats kinda what I thought, just looking for some other opinions
Got any recommendations for those parts.
I have sun coast in mine and I am happy with it.

Just start searching the net for rebuild kits.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors