P0500 & P0720? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-06-2010, 05:13 PM Thread Starter
DJM
Compression Ignition Addict
 
DJM's Avatar
 
Join Date: Sep 2005
Location: Springfield ,OR
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P0500 & P0720?

So to start off my trucks speedo quit workingand the O/D light was flashing so I pulled the codes and got P0500 speed sensor malfunction so I replaced the sensor on the pumpkin worked for a wile then it started doin the same thing but my tranny would shift wierd for a second every now and then and go back to normal and the speedo would either work or it would jump up and down for a second, also when I put it in park the motor would rev up for a second then idle back down. So I pulled codes again and got P0720 Output speed sensor malfunction so i replaced that still din't fix the problem now both codes come up. Any Ideas im lost

2001 Crew Cab, Auto
6in lift, 37Toyo's
DP F6 60eco,80tow,80eco,120
Wicked Wheel
Foil Delete
Isspro EV2 Guages
HPX Line
RiffRaff FRx
4" Exhaust
AFE Big Boost
FS 2500 Filter


DJM is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-06-2010, 06:02 PM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 1,248
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
Pull the insulation off the harness from the speed sensor. Look for chafed wires or insulation that is puffed up. That means corrosion on the inside. Did the sensor that you removed have a lot of stuff on it???? You may have something going wrong in the differrential and getting metal on the sensor.
ipz2222 is offline  
post #3 of 5 Old 01-06-2010, 07:11 PM Thread Starter
DJM
Compression Ignition Addict
 
DJM's Avatar
 
Join Date: Sep 2005
Location: Springfield ,OR
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yah there was a bunch of stuff on the sensor in the back. I pulled the 2 30 amp fuses under the dash not sure wich one is for the PCM drove it and the O/D light never came on but the speedo kinda figited around when I slowed down so I pulled the codes just now again and got P0603 Internal Control Module KAM Error and also P1000 OBD 11Monitor Checks Not COmplete. More Driving Required are those codes just from pulling the fuses? The P0720 and P0500 didn't come up this time but I only drove about 5 miles. What should I look for in the rearend if I pull the cover?

2001 Crew Cab, Auto
6in lift, 37Toyo's
DP F6 60eco,80tow,80eco,120
Wicked Wheel
Foil Delete
Isspro EV2 Guages
HPX Line
RiffRaff FRx
4" Exhaust
AFE Big Boost
FS 2500 Filter


DJM is offline  
post #4 of 5 Old 01-06-2010, 08:59 PM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 1,248
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
The 603 and 1000 codes are from pulling the fuses. On the side of the ring gear there is an exciter ring that the speed sensor gets the pulses from. Make sure all the little tits are on the ring.
I had one with a speed sensor code, replaced the sensor and still had the same problem. Spent hours traceing wireing and connections. everything cked good. Had another truck in the shop, pulled the sensor out of it and installed that sensor in problem vehicle. Problem fixed. Two bad sensors in a row.
ipz2222 is offline  
post #5 of 5 Old 01-07-2010, 09:14 AM Thread Starter
DJM
Compression Ignition Addict
 
DJM's Avatar
 
Join Date: Sep 2005
Location: Springfield ,OR
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
alright I will check that out thanks. I drove to work and back and it seemed to work fine but Im still gona look into the rear diff.

2001 Crew Cab, Auto
6in lift, 37Toyo's
DP F6 60eco,80tow,80eco,120
Wicked Wheel
Foil Delete
Isspro EV2 Guages
HPX Line
RiffRaff FRx
4" Exhaust
AFE Big Boost
FS 2500 Filter


DJM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome