Got a Bit of a Problem Here - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2010, 04:33 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Edmonton Alberta Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got a Bit of a Problem Here

I know you all hate edge an are probably going to poke an prod about me running it, but it is what it is an I wasn’t running around bagging on my truck, I was just putting down a busy icy road… Please Help…

So I was heading home today in rush hour traffic, when all of a sudden the tranny started to shift into 2nd an 3rd weird… When it shifted it would kind of jump into gear, causing the truck to slightly jolt… It did that for a few km’s, than I stopped at a red light, went to go an the motor reved up an the truck jammed into gear… So now that the trucks rolling it shifts into 2nd an 3rd fine… Stop at the next red, an the same thing happens only I was ready for it an gently reved up the motor until it engaged, still connected kinda hard… Long story as short as possible, this problem has got worse, an now it does it when shifting into 2nd an 3rd, but when it is connected everything is fine until the truck shifts or stops… The O/D light was not flashing an I tried taking it in an out of O/D… Also checked the fluid an it was perfect…

Made it home an parked the truck, didn’t even think about trouble codes… I will go out in a bit an set the truck back to stock an run the ol Edges Diagnostic…

Any help would be greatly appreciated… Thank you very much…
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-04-2010, 04:43 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Edmonton Alberta Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Reply With Quote Quick reply to this message
  #3  
Old 01-04-2010, 05:30 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Edmonton Alberta Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the tranny flushed an filter changed about a year an a half ago, an its been about 50 000 KM's, could it be something as simple as that?

What Does the torque converter do when its failing?

Any help would be greatly appreciated...

Thanks...



Henry...
Reply With Quote Quick reply to this message
  #4  
Old 01-04-2010, 05:36 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Hadley, Michigan/Lima, Ohio
Posts: 3,067
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thesmokinstroke02
sound slike you have tranny issues my friend. try taking the edge off and see hwat it does. put it to stock and drive er a bit. if this doesnt solve it your tranny needs some work. these trucks are notorious for blowin trannys
Reply With Quote Quick reply to this message
  #5  
Old 01-04-2010, 05:42 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,241
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yep tranny toast. how many miles? my old 7.3 with the edge did the same thing around 80k miles. cost me $1800 to get it rebuilt but that was a while ago.
Reply With Quote Quick reply to this message
  #6  
Old 01-04-2010, 06:39 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 563
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
i was having same similar problems just this week truck was in like a safe mode or limp mode, i didt have reverse and didt get any further than 2nd gear turns out i wasnt getting enough fluid to my clutches and they burned up... suks!!!
Reply With Quote Quick reply to this message
  #7  
Old 01-04-2010, 06:51 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Edmonton Alberta Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just went out an put the Evolution back to stock an tried to run a diagnostic on it an nothing came up... Went for a quick drive, didnt go fast or far, but it didnt do it...
Truck has 274 000 KM's...
So ya figure that the trannys right shot even tho when it does connect it holds like normal? I was kinda thinking that it might be the Torque Converter, but im no tranny mechanic...lol
Reply With Quote Quick reply to this message
  #8  
Old 01-04-2010, 07:03 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 563
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
Quote:
Originally Posted by F350Buster View Post
Just went out an put the Evolution back to stock an tried to run a diagnostic on it an nothing came up... Went for a quick drive, didnt go fast or far, but it didnt do it...
Truck has 274 000 KM's...
So ya figure that the trannys right shot even tho when it does connect it holds like normal? I was kinda thinking that it might be the Torque Converter, but im no tranny mechanic...lol
i ran the codes on mine but the trannie has seperate codes for itself jus so you know so get it tooken down to a mechanic to check the codes for it.
Reply With Quote Quick reply to this message
  #9  
Old 01-04-2010, 07:12 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Edmonton Alberta Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good to know, thanks man, i was kinda wondering if they would come up on the BS Edge Diagnostics program...

Soooo i guess i will be getting ahold of a tranny shop in the morning...

Thanks for getting back to me fellas...
Reply With Quote Quick reply to this message
  #10  
Old 01-07-2010, 10:18 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Edmonton Alberta Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So i havent been able to get the truck into a shop to get checked out... Took it for a little rip to go an get fueled up in the stock setting... Trannie felt perfect, better than ever(probably cause that Edge was turnrd off lol)... So i get to the Fuel station an fuel up, but notice that my rear passenger side tire is low as im cleaning all the garbage outa the truck a guy accumulates over a week... Anyways start the truck an pull up to the air pumps an fill the tire up, jump ina, an the truck wont move forward or back, tried for a minute an gave up... Went inside an told the gas jocky that the truck was going to sit there for a half hour or so cause its having trannie issues, he agreed not to tow it or anything an i ran across the street, bought the girlfriend supper, came back jumped in an everything was fine... WTF???

Is this how these trannies go out or what? Cause when its working it feels like its all there... Sorry for the long story, hope it makes sence...

Henry...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors