OD light flashed, then stopped... - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 11-11-2009, 09:38 PM Thread Starter
Serving Our Country!
 
Join Date: Aug 2007
Posts: 233
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
OD light flashed, then stopped...

My OD light was flashing for a while today. I shut off the truck and the light never came back. Truck seemed to shift fine even while the light was flashing.

I had it in the shop today for a (probably) un-related issue and was told it's showing a torque convertor code - didn't get the code darn it. Looks like I need to get a new injector driver module. Could this cause any issues that would make the OD light go?

How much are torque convertors and how hard are they to replace? Is that something that can be done by the average guy?

Thanks.

99 F350 Crew Cab Long Box 4X4
234 k and counting!!
PHP Phoenix - 5 positions
Banks Bighead Wastegate
Banks 4" exhaust
DIY NAPA Intake Mod
HPX Crossover line
Marinco Mod
MtPaul401 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-12-2009, 08:39 AM
DJM
Compression Ignition Addict
 
DJM's Avatar
 
Join Date: Sep 2005
Location: Springfield ,OR
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
it could be the cause of the OD light flashing when the tranny gets hot it will flash noticed that when I toasted mine also when the rear speed sensor is crapped out it will flash but usually the speedo craps out too.

2001 Crew Cab, Auto
6in lift, 37Toyo's
DP F6 60eco,80tow,80eco,120
Wicked Wheel
Foil Delete
Isspro EV2 Guages
HPX Line
RiffRaff FRx
4" Exhaust
AFE Big Boost
FS 2500 Filter


DJM is offline  
post #3 of 5 Old 11-12-2009, 08:41 AM
DJM
Compression Ignition Addict
 
DJM's Avatar
 
Join Date: Sep 2005
Location: Springfield ,OR
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Don't get a factory converter they suck aftermarket isn't much more you can spend anywhere from 600 to 1600 on a converter I paid around 750 800 for my tripple disc converter.

2001 Crew Cab, Auto
6in lift, 37Toyo's
DP F6 60eco,80tow,80eco,120
Wicked Wheel
Foil Delete
Isspro EV2 Guages
HPX Line
RiffRaff FRx
4" Exhaust
AFE Big Boost
FS 2500 Filter


DJM is offline  
post #4 of 5 Old 11-12-2009, 10:57 AM Thread Starter
Serving Our Country!
 
Join Date: Aug 2007
Posts: 233
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Talked to the shop this morning, they're still working on things. They say it's possible the IDM caused an electrical fault basically and gave a bad code about the convertor. They also said it could be a solenoid too. Hopefully it clears up with the new module.

Anyone ever have this happen?

After market is probably out of the question for now, so have to go stock. Found some for 200 or so.

I replaced the rear diff ABS speed sensor in Sept, and yes the speedo goes out when that goes bad.

99 F350 Crew Cab Long Box 4X4
234 k and counting!!
PHP Phoenix - 5 positions
Banks Bighead Wastegate
Banks 4" exhaust
DIY NAPA Intake Mod
HPX Crossover line
Marinco Mod
MtPaul401 is offline  
post #5 of 5 Old 11-12-2009, 12:53 PM
Member
 
Join Date: Jul 2009
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by MtPaul401 View Post
Talked to the shop this morning, they're still working on things. They say it's possible the IDM caused an electrical fault basically and gave a bad code about the convertor. They also said it could be a solenoid too. Hopefully it clears up with the new module.

Anyone ever have this happen?

After market is probably out of the question for now, so have to go stock. Found some for 200 or so.

I replaced the rear diff ABS speed sensor in Sept, and yes the speedo goes out when that goes bad.
I had the O/D light flash, and it was a P0743 which is a torque converter clutch electrical failure code. Also at the same time the TC wouldn't unlock when I tried to stop the truck. Luckily after coasting up the road a block or two it cleared up.

I'm going to replace the solenoid.
triumph406 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome