engine light - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-22-2009, 01:34 PM Thread Starter
Member
 
Chamberlain79's Avatar
 
Join Date: Jan 2007
Location: albany ky
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
engine light

I haver a 2001 7.3 witn 140,000 miles sometimes when i let it idel the check engine light will come on. I can put it in gear and push the throttle and it will not rev up or anything. After a few seconds the light will go off and it goes back to normal any ideas. Thanks
Chamberlain79 is offline  
post #2 of 5 Old 06-25-2009, 05:12 PM
Premium Member
 
RadarRider's Avatar
 
Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,589
Thanks: 5
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Chamberlain79 View Post
I haver a 2001 7.3 witn 140,000 miles sometimes when i let it idel the check engine light will come on. I can put it in gear and push the throttle and it will not rev up or anything. After a few seconds the light will go off and it goes back to normal any ideas. Thanks
I know this probably isn't good advice since I'm not sure what's causing your problem, but try getting your hands on a code reader or scan tool to see which code your truck's throwing.

"HEAVY" 2001 F-250 XLT 4x4 EC SB:
TW 6pos chip, S&B CAI, Monster 4" exhaust w/ Power Elbow, Big Head WGA, Technicooler, ITP boost fooler, Gen 1 Wicked Wheel, Six-Gun Tuner, Optima Yellow Tops, AutoMeter(Boost, Trans, EGT), CCV mod, MTS TC, MTS valve body, Trans Tech performance rebuild kit, TransGo shift kit, Hornblasters 242 Shocker Train Horns.

RadarRider is offline  
post #3 of 5 Old 06-27-2009, 04:01 PM Thread Starter
Member
 
Chamberlain79's Avatar
 
Join Date: Jan 2007
Location: albany ky
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have a superchips tuner that also reads codes i will check tomorrow.
Chamberlain79 is offline  
post #4 of 5 Old 06-27-2009, 04:25 PM
Member
 
Join Date: Nov 2008
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
sounds like the throttle position sensor is screwing up...
blacksmokingpowerstroke is offline  
post #5 of 5 Old 07-09-2009, 02:52 PM
Powerstroke.org Rookie
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Was it your throttle position sensor? I think I am having the same problem. Let me know what you had to do. Thanks,
nupy99 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome