rough idle and engine light - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-04-2007, 09:22 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Location: colorado
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
rough idle and engine light

I have a 99 7.3. when I start my truck when its cold, it runs fine, i will let it warm up for 10-15 mins then leave, about 2mins into driven it it starts runnin very rough, no smoke, engine light comes on, after it is up to operating temp the light goes out and it will run fine all day untill cold again. I have just replaced the ebp and the tube. Thanks dan
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-04-2007, 09:24 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: mooresville, nc
Posts: 1,436
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by badparker View Post
I have a 99 7.3. when I start my truck when its cold, it runs fine, i will let it warm up for 10-15 mins then leave, about 2mins into driven it it starts runnin very rough, no smoke, engine light comes on, after it is up to operating temp the light goes out and it will run fine all day untill cold again. I have just replaced the ebp and the tube. Thanks dan
check your fuel filter or pull any codes?
Reply With Quote Quick reply to this message
  #3  
Old 02-04-2007, 09:29 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Location: colorado
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I replaced the fuel filter a couple weeks ago, I thought that it had gelled up, there was a code po1316 if i remember correctly
Reply With Quote Quick reply to this message
  #4  
Old 02-04-2007, 09:39 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: mooresville, nc
Posts: 1,436
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hmm i have never seen that one.... i am also getting some weird codes to i beleive it has to do with the oil pressure to my injectors but ill let a tech help you out on that good luck
Reply With Quote Quick reply to this message
  #5  
Old 02-04-2007, 09:51 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Location: colorado
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks red73, good luck to u
Reply With Quote Quick reply to this message
  #6  
Old 02-05-2007, 03:19 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
you have a loose short harness under one of the valve covers , need to run injector buzz test and will tell you which side is lose ,then pul valve cover off and reconnect short harness ,ford make a clip to put under the ab to eliminate this problem
Reply With Quote Quick reply to this message
  #7  
Old 02-05-2007, 05:20 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Location: colorado
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how do you run a buzz test? what is the ab, I had ford look at it, the mech said it could be the #2 injector or harness under the valve cover, I havent looked yet, I have seen where the harness plugs into, I just can't afford to pay the dealer to fix it,
Reply With Quote Quick reply to this message
  #8  
Old 02-06-2007, 03:44 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
have to have a scanner that will run function tests , to run injector buzz test ,if the mech said it could be no. 2 cylinder ,very easy to pull drivers side valve cover off ,should find lose conection there , if dont ,may need to pull other side ,and look under there , may take a little time to find and fix but its better than paying a bunch of money ,it would just be your time
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:36 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors