Truck headed for the shop! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2009, 10:49 PM
Super Moderator

 

Join Date: Jul 2008
Location: Orangevale, CA
Posts: 11,404
Thanks: 10
Thanked 90 Times in 84 Posts
Feedback Score: 0 reviews
Truck headed for the shop!

Thursday after work, I was driving along running great. As I approached an intersection, I felt a shudder - looked down and tach was at zero. Shifted to neutral, tried to restart. No go. Cranks, but no start. Got the truck pushed off to the side of the road, called my son to help me get it towed home.

I checked the oil - good.
Fuel in the filter bowl. I drained it. But the fuel pump doesn't run when turning on the key to "Run".
Changed the CPS. The one I removed was put there under recall.
Checked the fuses under the dash for the PCM - good.
Owners manual said there also in one under the hood, checked it - good.
When key is in run, I get no "Wait to Start" light.
Have Service Engine light on.
I have a Hypertech programmer - Tried to read codes. It acted weird, but told me there were none detected...yet Service Engine light is on.
Tried to return to Stock to see if that would make a difference. It came back an told me it couldn't read the vehicle identification information.

I'm thinking the PCM is screwed. With no "Wait to Start", no fuel pump and the programmer not talking to the PCM, it appears nothing is being "controlled". Got to figure out the when/where of getting to the shop.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-18-2009, 11:41 AM
Super Moderator

 

Join Date: Jul 2008
Location: Orangevale, CA
Posts: 11,404
Thanks: 10
Thanked 90 Times in 84 Posts
Feedback Score: 0 reviews
Took the truck in on Monday - Tuesday, got the call. It is the PCM. Setting me back about $600 and change for parts/labor. They had to order it from Ford.

Just got off the phone with the guy...again......IT'S ALIVE!!!!!!!!!! I can go get it today!!!!
Reply With Quote Quick reply to this message
  #3  
Old 06-18-2009, 04:28 PM
ARMY MOM!!!!
 

Join Date: Nov 2008
Location: Colfax, Ca Sierra Nevadas
Posts: 3,050
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to korg70kbc
Thats GREAT Daryl....!!!!
My truck, not so sure at the moment. it has a odd vibartion-shudder-choke-?? I have a AE & am only throwing codes that seem to be about my GEM is causing issues also, along w/fuse panel. Got the part, just need to put it in.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors