injectors - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-03-2007, 06:07 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry injectors

I am having an injector issue with my 7.3 L. Left cylinder bank not firing in 2-4-6-8 , and weak on right cylinder bank. So I am trying to find out what would cause just one side to go completely out. I also put in a new fuel filter. Any help would be apreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-03-2007, 06:16 PM
Member
 

Join Date: Jul 2006
Location: phoenix
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im just a rookie but see if all the injector lines on that side of the engine come together at some place cause that could be a good spot for a clog.....or get someone to hook a computer up to it and see if it is throwing any codes
Reply With Quote Quick reply to this message
  #3  
Old 02-03-2007, 06:28 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did an injector test, that is how I found out the left bank was out. I guess what I'm trying to find out is why just one side would go out just like that, and if anyone came across this problem. Thanks for your help my97blowsblacks.
Reply With Quote Quick reply to this message
  #4  
Old 02-03-2007, 06:40 PM
Banned
 

Join Date: Dec 2006
Location: Maryland
Posts: 1,781
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via ICQ to Lord Tauk Send a message via AIM to Lord Tauk
How rough is the motor running? Just curious.
Reply With Quote Quick reply to this message
  #5  
Old 02-03-2007, 06:41 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Posts: 209
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
check you plug on the valve cover gaskit

Last edited by tubzz; 02-03-2007 at 06:44 PM.
Reply With Quote Quick reply to this message
  #6  
Old 02-03-2007, 06:46 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Lord Tauk View Post
How rough is the motor running? Just curious.
It knocks real loud and won't move in drive at all with pedal to floor. RPMs stay low.
Reply With Quote Quick reply to this message
  #7  
Old 02-03-2007, 06:55 PM
Compression Ignition Addict
 

Join Date: Aug 2006
Location: phx az
Posts: 480
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Albie30 Send a message via Yahoo to Albie30
If you tested the injectors you should also be able to check your hpop pressure That would be a good place to start
Reply With Quote Quick reply to this message
  #8  
Old 02-03-2007, 06:59 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Albie30 View Post
If you tested the injectors you should also be able to check your hpop pressure That would be a good place to start
thanks, I'll have my mechanic look into that. The truck is at the shop.
Reply With Quote Quick reply to this message
  #9  
Old 02-04-2007, 04:13 AM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hi i had a problem some what like yours first the wiring harnes is probly ok because the problem affects all cylinders i would look in two main areas your main fuel pressure from tank should be around 40 psi and check for volume also the eletric pump is located in frame rail under drivers cab the next area i would check is the high pressure oil pump it is located frount center under the fuel filter housing assembly should be around 600 psi at idle and around 3000 psi at 3500 rpm
Reply With Quote Quick reply to this message
  #10  
Old 02-04-2007, 05:11 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
just curious what test you ran to know which bank isnt firing ,injector buzz test or cylinder contribution test , that would lead me in a better direction to tell you what the problem is
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors