02 Ex Instrument cluster problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-04-2009, 06:58 AM Thread Starter
billman's Avatar
Join Date: Jul 2008
Location: Central NY
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
02 Ex Instrument cluster problem

I started my ex today and the instrument cluster was dead. the car started fine and ran. The #35 instrument cluster fuse was blown. When I replaced it and shut down the instruments worked with this exception: there were lights on the inst. panel on after shut down and key removal. HELP!
If anyone can shed some light It would be appreciated. I am traveling with the family on Sat. and do not want a problem............ If your answer is to complicated to write just pm me your # and I will call. I am worried that we will be 3 hrs. from home and have a problem. NYC will be no place for a broken excursion on a weekend.

*also posted in 911 .... sorry if repetitive.
billman is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome