Anyone rebuilt their own injectors? Doing it for the first time myself - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-15-2009, 09:30 AM
Member
 

Join Date: Nov 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone rebuilt their own injectors? Doing it for the first time myself

I am in Dental School and don't have the funds to buy new injectors. I had the money and took my truck to the shop the get the injectors put in and they charged me 1300 to rebuild two injectors and it did absolutely nothing at all. Should have just bought the injectors myself and put them in but with school keeping me busy I thought that would be the best thing to do so I could focus on my school. Well now that I have spent that money I cant afford to buy the injectors but I can afford a rebuild kit. I understand its relatively straight forward to rebuild the injector but the questions that I have are what problems might I run into and do they need to be flow tested and balanced before they are reinstalled? Basically all I know about rebuilding them is the rebuilding part not any of the other complications that I may have to trouble shoot while rebuilding and reinstalling them. I would really appreciate any advice anyone has. I have posted a few threads on here and every time several people reply with awesome suggestions and I just want to say THANKS!!
Ryan Lewis
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-15-2009, 09:33 AM
Oilfield Trash

 

Join Date: Jul 2008
Location: Bryan/College Station, TX
Posts: 26,302
Thanks: 4
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
Reply With Quote Quick reply to this message
  #3  
Old 05-15-2009, 09:47 AM
wriott
Guest
 
Posts: n/a
with the injectors that i have rebuilt i have found out that if you have some that are bad the rebuild kits wont fix it. ie plunger or barrel out of spec, etc. the DIY kits are easy to do as long as you ahve patients and know how to follow directions. you can do searches to check the tolerances of the popet vavle and others. i feel that it is very easy to do and there arent really any problems with it. just patience and FOLLOW DIRECTIONS
Reply With Quote Quick reply to this message
  #4  
Old 05-15-2009, 09:56 AM
Member
 

Join Date: Nov 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oh Ya by the way I forgot one part this is what the truck is doing. Doesn't start without being plugged in when its below 30. When it is warm outside it will start but loaps really bad after it is started until I give it throttle and then after I let off the rpms will drop really low and then come back up to a normal idle. Fuel mileage has gone down significantly. At around 45 to 60 mph if I try to maintain that speed on level ground it misses really bad. If I change the fuel filter and clean the air filter it will get better (still misses some) for about 600 to 1000 miles. I'm pretty sure that its the injectors as the wiring harness and valve cover gasket has been replaced. Please Help
Reply With Quote Quick reply to this message
  #5  
Old 05-15-2009, 09:58 AM
wriott
Guest
 
Posts: n/a
i would have a buzz test and a cyl contrubution test done
Reply With Quote Quick reply to this message
  #6  
Old 05-15-2009, 10:01 AM
Member
 

Join Date: Nov 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well when I took it to the shop they did that and on cylinder 2&8 the injectors came back bad so they rebuilt those and it didn't help
Reply With Quote Quick reply to this message
  #7  
Old 05-15-2009, 10:01 AM
wriott
Guest
 
Posts: n/a
rebuilt or replaced??
Reply With Quote Quick reply to this message
  #8  
Old 05-15-2009, 10:04 AM
Member
 

Join Date: Nov 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injectors 2&8 were rebuilt
Reply With Quote Quick reply to this message
  #9  
Old 05-15-2009, 10:05 AM
wriott
Guest
 
Posts: n/a
have you ran the buzz and contribution tests agian after installing them??
Reply With Quote Quick reply to this message
  #10  
Old 05-15-2009, 10:10 AM
Member
 

Join Date: Nov 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good question I don't know if they did I will go and see if I can get it done.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors