Rough running 99.5 7.3 until warm - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-11-2009, 01:30 PM Thread Starter Rookie
RRlocoENGR's Avatar
Join Date: Jan 2007
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rough running 99.5 7.3 until warm

My 99.5 7.3 in my F350 crew cab dually runs rough when first started, worse the colder it is outside.

If I plug the block heater in, it runs fine. If I crank it and allow it to warm for about 15 minutes it runs fine.

If I drive before warmed up completely, it shudders and has very little power. If I shower down on the throttle briefly, the rough running goes away immediately. So, either being warmed up or showering down on the throttle solves the rough running.

Injector problem or something called a pedestal valve??? problem? I have heard that these motors have some type of valve on the base of the turbo that reduces power when cold???

Truck runs fine when warm, but a pain when cold!

Thanks for any input!

Pensacola, Florida

1999.5 F350 crew cab dually PSD
Airaid intake 400-222, 4 inch turbo back exhaust, Diablo Sport Predator Tuner.
RRlocoENGR is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome