Code Help! please - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-24-2009, 02:31 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: Bastrop, Tx.
Posts: 443
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Drepka
Code Help! please

Ok like I said earlier this week, my truck engine light goes on and off when it wants. Before it didn't feel like I was losing any power but now I can tell that there is definately a power decrease when the light is on, maybe like 15 to 20 percent. When the light is off it runs just fine.


I scanned and got the folowwing codes:



1. P1280 ICP circuit out of range/ low


2. P0603 Internal control module KAM error


3. P1211 ICP pressure above/below desired

The truck died on me once after i went to take off from idling for about 15 minutes. Started right back up.

Then i was in line at the bank with the light off and it suddenly came on and the truck almost died ( sputtered ) and then kept running with light on.



???????????????????????? help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-24-2009, 02:36 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Try pulling the plug on the ICP sensor on see if there is oil in the sensor. If there is oil in the sensor its shot. The sensor is on the driversside valve cover towards the front. There is a thread in the 7.3 tech files that will show all the locations of the sensors incase you can't find it.
Reply With Quote Quick reply to this message
  #3  
Old 04-24-2009, 02:53 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: Bastrop, Tx.
Posts: 443
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Drepka
The plug area was full of oil......is that it those dang things are 175 at Ford, anywhere cheaper???? What would cause that? And what is the KAM error????????????????????

Thanks.
Reply With Quote Quick reply to this message
  #4  
Old 04-24-2009, 04:01 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I bought my sensor on ebay for 65 bucks. The KAM error is a common code. I think it is associated with having a chip. Its a harmless code.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors