Studder/surging no more then 18lbs boost - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-09-2009, 10:10 PM
Powerstroke.org Rookie
 

Join Date: Aug 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Studder/surging no more then 18lbs boost

1999 F250 SD 7.3

Just had the turbo rebuilt (Turbo Resource) new fuel filter, rebuilt trans etc.
When accelerating when I hit 18lbs boost the engine starts to fall off and feel it studdering. The pop-off is set for 30lbs. I have a super chips programmer and its set at performance tow. When just crusing at 55 to 60 I can feel a shudder, I thought it was the trans but still does it after rebuild.
This is driving me nuts. I talked to the owner of Tubo Resource and he has the same set=up as I do in his truck and he easily gets 24+ lbs of boost/
No trouble codes present either.
Could a weak pick-up pump cause this? IPR valve? I use this truck to tow and really need it to run right.
Any help or ideas would be great
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-09-2009, 10:28 PM
Banned
 

Join Date: Nov 2007
Location: Los Gatos CA
Posts: 733
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You are loosing fuel or HPOP pressure (drives injectors). Check for gunk in a fuel screen in the pressure regulator on the side of the fuel filter housing.
Reply With Quote Quick reply to this message
  #3  
Old 04-13-2009, 09:27 PM
Powerstroke.org Rookie
 

Join Date: Aug 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Please help me

So, here's the latest. I retuned the super chips to stock and the surging problem went away and I could get up to 25 lbs of boost with no surging. Then I reprogrammed it to performance and got up to 28+ lbs of boost with no surging, but was afraid of hurting the engine. I then reprogramed to performance tow and BAM, max 18 lbs of boost, surging at that rate and after shifting without overdrive engaged 18lbs max boost with continued surging!!
Almost feels like the govener was kicking in.

This has me totaly baffeled along with a couple people in the know, doesn't make any sense.

I'm going to call superchips to see if my programmer has a fault in it's program when in performance tow.

Another thing I've noticed recentley was the battery light coming on and going of. No codes present for anything.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors