Is my engine shot? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-25-2009, 03:09 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Fulton, NY
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is my engine shot?

I was trying to jump start my E350 yesterday (bad glow plugs) with my truck. It had been idling in the driveway for about an hour at the time because I was messing with some other stuff, and I noticed that my truck sounded like it was loading up or somthing. So I get in it & rev it up a couple of times, and all of a sudden it starts making a really loud popping noise out of the intake! It sounds like a backfire out of the intake every revolution of the motor? Anyone have any idea's?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-27-2009, 03:13 PM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by prdcustoms View Post
I was trying to jump start my E350 yesterday (bad glow plugs) with my truck. It had been idling in the driveway for about an hour at the time because I was messing with some other stuff, and I noticed that my truck sounded like it was loading up or somthing. So I get in it & rev it up a couple of times, and all of a sudden it starts making a really loud popping noise out of the intake! It sounds like a backfire out of the intake every revolution of the motor? Anyone have any idea's?
Any SES light? Have you pulled the intake & checked the turbo?
Reply With Quote Quick reply to this message
  #3  
Old 03-27-2009, 04:46 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Fulton, NY
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just found out it has 700 miles left on the warranty, so I'm gonna let them look at it. I removed the chip & overboost anihalator (spelling?), so the only thing still visible is the intake, gauges & stack. I hoping they dont give me a problem, but I'm sure they will come up with some kind of BS to deny the claim. The other thing that may give me a problem (if they are smart enough to look at it) is the hole I cut in the plastic pcm mount to run the wire out to the switch? We'll have to see
Reply With Quote Quick reply to this message
  #4  
Old 03-27-2009, 04:57 PM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by prdcustoms View Post
I just found out it has 700 miles left on the warranty, so I'm gonna let them look at it. I removed the chip & overboost anihalator (spelling?), so the only thing still visible is the intake, gauges & stack. I hoping they dont give me a problem, but I'm sure they will come up with some kind of BS to deny the claim. The other thing that may give me a problem (if they are smart enough to look at it) is the hole I cut in the plastic pcm mount to run the wire out to the switch? We'll have to see
Well, good luck, prd, & let us know how you make out!
Reply With Quote Quick reply to this message
  #5  
Old 03-27-2009, 07:58 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bent pushrod Happened to me in December. Ford dealer dont know y happenes from time to time. All I did was start the truck and bang bang bang. $2.95 part if u are mechanicly inclined u can change it urself I did mine never had prob since.
Reply With Quote Quick reply to this message
  #6  
Old 03-27-2009, 08:00 PM
Premium Member
 

Join Date: Dec 2008
Location: lubbock tx
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
try your ebpv if it was cold outside when it happen
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors