03 7.3 throttle dies and so does dash - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-23-2009, 10:31 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2008
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 7.3 throttle dies and so does dash

Hi, I recently bought a 03 7.3 psd with 90k on it. Ocassionally when driving for no apperent reason the throttle will stop working and the dash will go crazy then all gages will die. The truck will idle but that is it. Then all at once it will come back and work just fine. I have had a similar problem when the OD wire rubs through on the colmn but that would blow the ignition fuse and would not work untill I replaced the fuse. This problem comes and goes without any altercation or repair. Any thoughts would be appreciated, thanks in advance.
cumminstroker is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-23-2009, 05:40 PM
Compression Ignition Addict
 
RadarRider's Avatar
 
Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cumminstroker View Post
Hi, I recently bought a 03 7.3 psd with 90k on it. Ocassionally when driving for no apperent reason the throttle will stop working and the dash will go crazy then all gages will die. The truck will idle but that is it. Then all at once it will come back and work just fine. I have had a similar problem when the OD wire rubs through on the colmn but that would blow the ignition fuse and would not work untill I replaced the fuse. This problem comes and goes without any altercation or repair. Any thoughts would be appreciated, thanks in advance.
How's the condition of your batteries? Sometimes when they get weak, you'll experience some funky stuff. Last year, one of my batteries started going weak & sometimes the truck would die......while I was driving & then start running again!!! Other times, I'd pull up to a gas station, fuel up for about 5-10mins., & then when I go to start it, it would crank once & then wouldn't start with my dash going crazy. If I wait a few seconds, it would start up fine. Give 'em a try! Either way, here's a

"HEAVY" 2001 F-250 XLT 4x4 EC SB:
TW 6pos chip, S&B CAI, Monster 4" exhaust w/ Power Elbow, Big Head WGA, Technicooler, ITP boost fooler, Gen 1 Wicked Wheel, Six-Gun Tuner, Optima Yellow Tops, AutoMeter(Boost, Trans, EGT), CCV mod, MTS TC, MTS valve body, Trans Tech performance rebuild kit, TransGo shift kit, Hornblasters 242 Shocker Train Horns.

RadarRider is offline  
post #3 of 6 Old 03-23-2009, 05:58 PM
Powerstroke.org Rookie
 
beerman1's Avatar
 
Join Date: Jul 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
do you have an edge programmer on your truck?
beerman1 is offline  
post #4 of 6 Old 03-23-2009, 07:19 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2008
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just bought the truck from a dealer as a trade in so Im not sure if it has an programmer installed on it r anything about it for that matter, there is obvously not a permanent style programmer but could very well have a plug in tune as it seems to move pretty good for a 7.3 with 8" of lift. I will see if I can contact the previous owner and find out. As far as the batteries, they hold a charge well and it always starts righ up. Thanks for the input so far and keep the thoughts comming!
cumminstroker is offline  
post #5 of 6 Old 03-24-2009, 10:10 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2008
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, for anyone who cares, I fixed it today. I drove the truck until it acted up (at which time I was in the middle of an intersection), I had the fuse box cover off and I began pushing on the fuses and relays, all at once the pedal and dash came back alive.........then died again. So I stuck my hand behind the fuse pannel and pushed on the wires and it worked untill I got home. I picked up a new fuse pannel from Ford and it works great!
cumminstroker is offline  
post #6 of 6 Old 05-12-2009, 12:15 PM
Powerstroke.org Rookie
 
Join Date: Oct 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm having the same problem with my 03. Radio goes off and power windows won't operate. Seems I hit a couple bumps in the road and bingo they work again. I'll try pushing on the fuses and the panel. Thanks, Tom
tdlee is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome