2001 Ingition issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-09-2007, 03:39 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 2001 Ingition issues

Hi all, just stumbled across this site, want to see if I can fix before spending the dough at a dealer...

2001 Powerstroke - just got home from 4 day vacation, truck turns, but won't fire. I notice a buzzing/ clicking sound in dash... Please help!!!

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-09-2007, 03:41 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check all your fuses and get back to us.......
Reply With Quote Quick reply to this message
  #3  
Old 01-09-2007, 03:44 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was hoping you'd answer Marc - looking thru the ads, I noticed you have a lot of responses... I'm running out to truck, be back in a few. Thanks!!
Reply With Quote Quick reply to this message
  #4  
Old 01-09-2007, 04:03 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
checked all fuese (under hood and dash) all seem fine. tried to start again - batteries seem week... charging as we speak. Could this just be a fatigued battery issue?
Reply With Quote Quick reply to this message
  #5  
Old 01-09-2007, 04:15 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck fired, noticed ABS light is on now! Going to drive around the block, charge battreries, then head to auto store for battery test. Thanks for your help! Will be back
Reply With Quote Quick reply to this message
  #6  
Old 01-09-2007, 05:55 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question ???

OK,

charged batteries (to some degree), fired up fine. Drove to Automotive parts store - on the way over I noticed it wasn't charging well... they determined Alternator was bad. Replaced altenator, gauge read it was fine, drove 1 block away and noticed guage was low again... does this indicate I have bad batteries??? Should I try charging them overnite 1st, then testing them tomorrow? Please help! Thanks from PA!
Reply With Quote Quick reply to this message
  #7  
Old 01-09-2007, 05:58 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: kannapolis NC
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dead batteries and a new alt, good way to kill a good altenator
Reply With Quote Quick reply to this message
  #8  
Old 01-09-2007, 06:04 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mako,

Thanks for the reply... I drove about 10 minutes like that, do you think I did any damage? I plan to charge ovenite and try again in the am... I'll have the batteries tested. Sound like a good plan to you?
Reply With Quote Quick reply to this message
  #9  
Old 01-09-2007, 06:07 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: kannapolis NC
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
try that and see I had to replace my batteries and altenator at once
Reply With Quote Quick reply to this message
  #10  
Old 01-09-2007, 06:11 PM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,018
Thanks: 109
Thanked 95 Times in 87 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
make sure that they disconnect the grounds on the batteries when they do the tests
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors