5 codes and it runs terrible - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-09-2007, 02:55 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: mt. washington, ky
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slow00si
5 codes and it runs terrible

Ok i just bought this truck a week ago its a 2000 f250 psd and when cold you cannot drive it because it wont even pull itself hardly, and if you try to rev it any to help it warm up it doesnt want to rev or once it does rev it misses bad but once warmed up doesnt seem to miss too bad but to me it still has a miss.

And im new to the psd's but this thing is not impressive and gets about 12mpg without being on it, and the only mod is a airraid intake and i did the zoodad mod the other day while the coolant was draining to do a thermostat. Also sometimes once i start it after a couple seconds it makes a real loud sucking sound thats deff. not normal so if i turn the truck off and back on the sound doesnt come back until the next morning?

I scanned the truck after i was done working today, im a import performance tech i build motors and turbo honda's etc so i have all the scantools and whatnot but im totally new to diesels as this is my first one and none of my friends have any psd's, so im hoping some of you all can help me out with these codes and tell me what needs to be done to fix it because i need to learn more about this thing and get it running like it should before i get mad and sell it.

p1280 icp ckt out of range, what is the icp?


p1316 idm codes detected, i searched and found that this is the inj driver module, so is the module going bad making the miss? and where is it located?



p0541 int air heater a circuit low

So if any of you can point me in the right direction or help out i would greatly appreciate it

Last edited by slow00si; 01-13-2007 at 12:55 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-09-2007, 05:28 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: mt. washington, ky
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slow00si
also forgot to add that the check engine light is not on but when i scan it the codes are there
Reply With Quote Quick reply to this message
  #3  
Old 01-09-2007, 06:01 PM
Serving Our Country!
 

Join Date: Nov 2006
Location: GREAT LAKES,IL
Posts: 636
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
not sure were to help you at on those codes but lookes like the dealer screwed you. he may have known about this and cleared the light. you can clearthe light but not the codes. its easy to do. i usally try and take a scanner with me when i buy a tuck
Reply With Quote Quick reply to this message
  #4  
Old 01-09-2007, 11:38 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Kokomo, In
Posts: 402
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to House22
ok how many miles on the truck, does it sound rough? if you have a good scan tool, take the truck out and get it warmed up and get engine oil warm and do a cylinder contrubtion test if a cylinder or two fails its injector bad, my tow rig with 170k had the idm code put failed 2 cylinders on contrubtion. put new injs in and it runs like a champ
Reply With Quote Quick reply to this message
  #5  
Old 01-09-2007, 11:43 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Kokomo, In
Posts: 402
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to House22
p1280 icp ckt out of range, what is the icp? Injector control pressure

p0237 turbo boost snsr a ckt low

p1316 idm codes detected, i searched and found that this is the inj driver module, so is the module going bad making the miss? and where is it located? the idm is located in the drivers fender well

p1247 turbo boost pres low due to poor performance

p0541 int air heater a circuit low, is the plug in the midle of the turbo thats goes to a solienoid


Id deff try to do the cylinder contrubtion, also can do a buzz test and see how the injectors sound all should be the same and loud and crisp
Reply With Quote Quick reply to this message
  #6  
Old 01-10-2007, 04:21 AM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: mt. washington, ky
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slow00si
Quote:
Originally Posted by House22 View Post
ok how many miles on the truck, does it sound rough? if you have a good scan tool, take the truck out and get it warmed up and get engine oil warm and do a cylinder contrubtion test if a cylinder or two fails its injector bad, my tow rig with 170k had the idm code put failed 2 cylinders on contrubtion. put new injs in and it runs like a champ
it has 150k on it but the guy i bought it from ran farm diesel through it with no fuel additive and yea it sounds rough to me and we have a snap-on motus so ill try the contribution test when i get to the shop today,
Also where is the cheapest place to get stock replacement injectors, the dealer or is there a place to get them online cheaper? and what else would i need to do the job valve cover gaskets and anything else?
Reply With Quote Quick reply to this message
  #7  
Old 01-10-2007, 12:38 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Kokomo, In
Posts: 402
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to House22
just injectors is it, the havle cover gaskets are a plastic compiste and can be reused, also a vacum pump is handy to suck the oil out of the injector bores.
For stock replacment check out Beans Diesel Performance

150k and farm fuel i bet you have a few injecotrs that fail. on my snap on scan tool i havce to drive the truck around 15-20 mins then do the contrubtion test with truck in driver and parking break set
Reply With Quote Quick reply to this message
  #8  
Old 01-10-2007, 03:08 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: mt. washington, ky
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slow00si
it only has about 15k on the farm fuel and i cleared the codes when i got to the shop today and went around and drove it for about 20 minutes after a 20 minute drive to work and the only codes that came back are

p0541 the intake air heater circuit low

and a new one p1211 icp above/below desired, so i checked the data on the scanner and it is showing a reading of 0 so i ordered a new sensor which should be in tomorrow and im going to test the int air heater relay tomorrow

I guess the other codes are left from when it had the banks six gun tuner on it that threw an emmidiate cel so i removed it.

I also did a buzz test on all the injectors and they all tested ok so i did the glow plug test and that threw the int air heater code, but ill try doing the buzz test again tommorow with it in drive and the parking break on to see if it makes any of them fail.
And also with the old codes erased it seems to run quite a bit better once warm but when cold it still doesnt pull itself or want to rev.
Reply With Quote Quick reply to this message
  #9  
Old 01-11-2007, 06:09 AM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Location: mt. washington, ky
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slow00si
Ok I did some more testing on it this morning and with doing the koer scan it brought up p0476 exh pres ctrl valve perform, and a new memory code of p1670 ef feedback signal not detected which showed up after the koer test so i guess they go together and it still has the p0541 and p1211

And i also did the cylinder contribution test, and it brought up p0284 cyl 8 contribution/balance fault so does that mean that #8 needs to be replaced? Also that is the injector they call the cackle one correct? if so why and does it just use one of those for #8 only?
Reply With Quote Quick reply to this message
  #10  
Old 01-11-2007, 06:20 AM
I don't know nuttin....

 

Join Date: Jul 2006
Location: Tuttle, OK
Posts: 17,160
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by slow00si View Post

p1280 icp ckt out of range, what is the icp?

p0237 turbo boost snsr a ckt low

p1316 idm codes detected, i searched and found that this is the inj driver module, so is the module going bad making the miss? and where is it located?

p1247 turbo boost pres low

p0541 int air heater a circuit low

So if any of you can point me in the right direction or help out i would greatly appreciate it

Maybe Marc will chime in this morning and help....maybe you got a bad ICP sensor or poor oil pressure to the injectors. Check the oil level in the HPOP (high pressure oil pump), make sure it's almost full to the top .
Boost pressur being low might be a bad MAP sensor?? Maybe a boost leak from one of the rubber boots??? that might explain the sucking sound but it's strange you don't hear that all the time.
I'm just guessing here and someone else will be along to help more.

Last edited by Clay Henry; 01-11-2007 at 06:36 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors