hesitation in the PSD 7.3 - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-02-2009, 04:19 PM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hesitation in the PSD 7.3

I have a 2002, with 165,000 miles on it, new garret 38R turbo, bellowed uppipes new intercooler boots, new intercooler new intake Y o ring that meets the outlet compressor, New IPR new 3/8 line hose, origional fuel pump. The truck just has hesitation and doesnt seem to take off like it should around 2,000 rpms, Has a steady stream of smoke out of the oil fill cap. I have stock program in it at moment till this is figured out, Also turbomaster wastegate and can get 20lbs of boost WOT in stock program. I have had the valve covers off awhile back and the UVC harness dont appear be damaged. Origional ICP sensor but doesnt have oil in it if I take off the connector. What could be the problem? Low fuel pressure? Injector O rings cause low pressure? Have a new HPOP, good oil, good air filter, Could weak fuel pressure cause all this or ICP sensor? otherwise it has to be injectors or motor weak. Any help Appreciated
powerv8stroke is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome