High Flow Oil Pump - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-11-2006, 12:37 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2006
Location: SANTA FE, TEXAS
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
High Flow Oil Pump

Need advice, I installed an Edge Evolution Tuner on my 02 7.3 several days ago then pulled my travel trailer on a 200 mile trip, drove between 60-70 mph on the trip kept truck below 2000 rpm. upon leaving the campground on Sunday I noticed that my truck was dumping alot of oil onto the ground. Long Story short had to have the truck towed to a dealership and it was diagnosed as the HIGH FLOW PUMP.

Question is: could the programmer have anything to do with this?

Set programmer on tow safe mode 60 hp 125 lbs torque.

I have also installed a magnaflow 4" turbo back, AEM Intake, Autometer Gauges.

Phils Good
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PHILS GOOD is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-11-2006, 03:45 PM
Powerstroke Diesel Enthusiast

 
Diesel_Diagnostician's Avatar
 
Join Date: Dec 2006
Location: Grey Bruce County
Posts: 223
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
If she was on her way out, she was on her way out..more like one of those coincidences...

-You can think I'm wrong, but that's no reason to quit thinking-

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Diesel_Diagnostician is offline  
post #3 of 4 Old 12-11-2006, 03:51 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 5 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
odds are the high pressure oil pump is fine....one of the o rings for one of the quick connect fittings probably jut blew out....bout 50 bucks in parts and 250-450 in labor depending on the local labor rate
mschn99 is offline  
post #4 of 4 Old 12-12-2006, 05:58 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2006
Location: SANTA FE, TEXAS
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the response guy's.

I actually had good luck yesterday, the dealership called and my truck was ready around 4:00pm yesterday, I guess business was slow. any how they said they replaced the entire pump and fuel regulator. The only thing I was dissapointed in was that they did not change the oil. According to the spread sheet they only added oil with a diesel dye to check for leaks.

oh yeah had to pay the 100.00 deduct not a big deal considering the price of the parts and labor if it was out of warranty.

I would really like to re install the tuner back in my truck I was really impressed with the performance of it while pulling not to mention the boost in fuel milage. Just a little skiddish now.

Phils Good
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PHILS GOOD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome