MAY DAY-MAY DAY- 2000 PSD BROKEN R MOUNTS - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-29-2014, 12:14 AM Thread Starter
Powerstroke.org Rookie
 
Apolloofmax's Avatar
 
Join Date: Feb 2014
Location: MAXEYS GA
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
MAY DAY-MAY DAY- 2000 PSD BROKEN R MOUNTS

Gals and Guys,


Drove my PSD to repair shop sat for 3 weeks,one week past the two week scheduled repair date. Was having dead knock sound coming from the intake and the dashboard oil gauge showed zero oil pressure. Tired of waiting drove it home to repair myself. Took off driver's side valve cover and found the # 6 rocker arms MOUNTS broken. The rods are still straight. Would this have caused the zero oil pressure reading? What are the best pushrods and rocker arms to install? Added a few photos.

Thanks


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Apolloofmax; 03-29-2014 at 03:55 AM. Reason: Add photos
Apolloofmax is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-29-2014, 04:09 AM
Compression Ignition Addict
 
schlutzer's Avatar
 
Join Date: Apr 2012
Location: Stratford, Ontario
Posts: 2,438
Thanks: 34
Thanked 138 Times in 122 Posts
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
Feedback Score: 0 reviews
I bet your gauge is ****ed. Pick up a cheap manual gauge and verify. Truck wouldn't run without oil pressure .

As for what parts to use. OEM is fine unless you want to go for big power later

Please check out my 7.3 Enthusiast Facebook group! All are welcome!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
schlutzer is offline  
post #3 of 3 Old 03-29-2014, 04:21 AM Thread Starter
Powerstroke.org Rookie
 
Apolloofmax's Avatar
 
Join Date: Feb 2014
Location: MAXEYS GA
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks, OEM...
The push rods with an eye inspection look straight and one of the balls

for the rocker is missing. Got the broken off pieces from the mount. I will use

a magnet to search for the other. I dropped one push rod to the right side of

where the rockers would be down another hole trying to see if I could set it

where it would belong. I can still see it and this I will get with a magnet

also.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Apolloofmax is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome