Bad ICP - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-17-2014, 07:03 PM Thread Starter
Compression Ignition Addict
 
RAMKILLER97's Avatar
 
Join Date: Sep 2011
Location: Hull, MA
Posts: 298
Thanks: 3
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bad ICP

So this morning I went to start my truck, it was about 17* with a windchill of about 4*. Anyway when I cycled the GP the cel came on. I figured it was the ebpv because it has been throwing a code every now and again on cold starts. Well I crank the truck over and it ran like crap. So I immediately plug in my cheap scanner and pulled a p1280. It's the only scanner I got up in mass, I know some people in jersey with good ones but I'm 5 hours from there. Anyways I get the truck to work, about 2 miles down the road and leave it till about 630 this evening. I pulled it into the garage and attempted to pull the plug on the sensor to check if it would cure the issue and let me know for sure it's the sensor. Well I wiggled on the plug and managed to rip the sensor in two. Yea, so now it's deffinitly broken, but with how easy it was to break like that it had to have been bad I would guess. Since I broke it I have tried to duplicate the idle issue and it hasn't returned after about 4 restarts of the truck. So I guess with it essentially being unplugged it was the problem? But what I'm asking is do you guys think the sensor was the original problem? I know it's a problem now obviously. Also I am currently not running tunes with my single shots, I got the chip at dyno proven getting re tuned due to a GP issue in the tuning. Here's a pic of the sensor, I showed it who was boss...
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	60
Size:	91.3 KB
ID:	258921  

2003 Excursion Eddie Bauer 7.3
6 Inch ProComp Lift, 315/75/16 BFGoodrich All Terrain Tires, BTS Transmission, 175/100 P.I.S. Injectors, PMF Traction Bars, Garrett 38r, International Up Pipes, Dyno Proven Tunes, 6.0 Transmission Cooler, CCV mod, MBRP 4" Turbo-Back Exhaust, RiffRaff Over Boost Code Regulator, Moto Metal MO951 Black Rims, Dual Sky Jacker Steering Stabilizers, GlowShift Gauges, Mile Marker 449SS Lockout Hubs, 6637 Intake.

Putting this old PMR truck to the test....
RAMKILLER97 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome