engine cuts out, almost like it's missing - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-16-2014, 07:24 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
engine cuts out, almost like it's missing

Hi. My 99 7.3 f350 developed a problem the other day. After driving for about fifteen min out started to stutter and cut out almost like it was missing. Every couple of seconds this would happen, just cut out for a split second. A little background on the truck, I've had it got three years now, it's stock aside from the exhaust falling off a couple weeks ago and I got rid of the air box for a napa filter. It has done this before but only once and at very random times, I never could put any rhyme or reason to when it would happen but again it would only happen once. This time it was happening constantly for about a half mile until I pulled over and shut it off. I let the truck sit for the day there and came back to it after work. Started it up and drove it ten of the fifteen minutes home until it started again. So I pulled over, shut it of and restarted it to see what would happen. Well after restarting it, it ran fine the last five min home until just before I pulled in the driveway. Oh and when it started doing this consistently the service engine light came on, which never happened before. Seeing the light cane on I tried using my odb2 scanner to see if I could get an answer but it won't read it. I did some reading of my symptoms and it sounds like it could be any number of things from a cps, to a bad hpop, or even the injector harness or injector o-rings. If you guys could give me any help on either what could be wrong or how to test things to figure out what is wrong, that would be great. Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-18-2014, 02:13 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: Monterey Bay, CA
Posts: 346
Thanks: 2
Thanked 14 Times in 13 Posts
Feedback Score: 0 reviews
Absolutely sounds like a bad CPS.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors