Ticking sound under load: - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-31-2014, 09:23 AM Thread Starter
Powerstroke.org Rookie
Ryans71's Avatar
Join Date: Jan 2006
Location: Milton, Wa
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ticking sound under load:

I did a search and read through some of the posts, but my "tick" is a bit different. No abnormal tick at idle. The only time I really hear the ticking is when I get on it pretty good. As soon as I let off it goes away.

No lack of power.

Any suggestions?


'02 F350 Dually Crewcab 4x4, PSD, Auto, Lariat, Longbed, 4" exhaust, AIS intake

'71 Bronco, 302EFI, D44 & 9" w/ARBs, 4.27's, alloy shafts, CTMs, 37" MTRs, onboard air, 8274, 4 wheel disks, 4" lift w/ Extended Arms

'04 Arctic Fox 990 Camper
Ryans71 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome