99 7.3 problems - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-10-2013, 05:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
99 7.3 problems

hey guys I got a 99 7.3 powerstroke with a straight pipe and a ts 6 position. the problem is some times it will run fine then other times its slow and has no acceleration. sometimes under wot it will run like a raped ape then will lose power. then sometimes will just off after a blip of the throttle and wont restart for awhile. changed icp senor bout a month ago and cps yesterday didn't help at all. any help welcomed!
strokin 6.0 05 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-14-2013, 06:02 PM
Compression Ignition Addict
 
lookin4myPSD's Avatar
 
Join Date: Nov 2011
Location: Bradenton, Florida
Posts: 168
Thanks: 8
Thanked 7 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Erm...my suggestion would be with the IPR (Injection pressure regulator), if it gets stuck or somehow allows the incorrect pressure, it may kill the power. And, if it has some sort of correlation to the fuel level, the problem may be in fuel delivery. I say IPR though because I had a similar problem.

If you ever think something I post is ridiculous or uneducated, just remember that I probably learned it from here.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Early 99 F250 ECLB,
T-500, 6637, CCV Mod, Foil delete 4" downpipe to 5" straightpipe
TS 6 Position Chip (Will accept donations for custom tunes!), Bridgestone Dueler AT 285/75R16
Pro-comp Trans temp, Pyrometer, boost and HPOP gauges
lookin4myPSD is offline  
post #3 of 3 Old 12-14-2013, 07:01 PM
Powerstroke.org Sponsor

 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 10,186
Thanks: 835
Thanked 581 Times in 534 Posts
Mentioned: 283 Post(s)
Quoted: 640 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by lookin4myPSD View Post
Erm...my suggestion would be with the IPR (Injection pressure regulator), if it gets stuck or somehow allows the incorrect pressure, it may kill the power. And, if it has some sort of correlation to the fuel level, the problem may be in fuel delivery. I say IPR though because I had a similar problem.
I agree, possibly hpop itself or possibly fuel pump has intermittent hiccups.

Sent from AutoGuide.com Free App
Corey@CNCFAB is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome