EBPV Problems. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-02-2013, 06:22 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
EBPV Problems.

Hi there, im new to the diesel world and its still a learning procces so please bare with me. I bought the truck last march while it was still fairly chilly 30s and 40s i dont ever remeber the ebpv closing nor the high idle kicking on. this past couple weeks it has been in the high 20s low 30s and the past 2 days the ebpv decided to start closing and opening it hasnt worked at all yet this year besides the past couple days. and still no high idle when i fire it up. After some reading i unplugged the regulator at the turbo pedastal but now it seems like the valve is still partially stuck closed. there is no hissing noise but the exhaust does not sound normal and the truck is sluggish. Is there anyway to know for sure that the valve is all the way open besides pulling everything apart to look and what would cause this to happen along with no high idle? on a side note my fuel milage is averaging 10-12 mpg normal driving. any help would be much appreciated. Thank you.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-02-2013, 06:25 PM
7.3 4 Ever! Nothing else!
 

Join Date: Aug 2012
Posts: 4,169
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Why did you unplug it, the EBPV doesnt kick in right on start up, when you let it run for 2-3 mins then the high idle will kick on. plug it back in and see if it kicks on?
Reply With Quote Quick reply to this message
  #3  
Old 12-02-2013, 06:36 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I unplugged it because i was tired of my truck sounding like a jet everywhere i went. I drove it for almost 4 hours straight yesterday and the whole 4 hours the valve was opening and closing. I start my truck up and let it run for 5-10 minuets every morning. The ebrake light comes on but no high idle. I dont ever remember the ebpv working last winter and its been cold for a month or so now. why would it start doing it now. ive driving it on days in the teens and the valve didnt close.
Reply With Quote Quick reply to this message
  #4  
Old 12-02-2013, 06:37 PM
7.3 4 Ever! Nothing else!
 

Join Date: Aug 2012
Posts: 4,169
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by firefighter33 View Post
I unplugged it because i was tired of my truck sounding like a jet everywhere i went. I drove it for almost 4 hours straight yesterday and the whole 4 hours the valve was opening and closing. I start my truck up and let it run for 5-10 minuets every morning. The ebrake light comes on but no high idle. I dont ever remember the ebpv working last winter and its been cold for a month or so now. why would it start doing it now. ive driving it on days in the teens and the valve didnt close.
sounds like a stuck valve....pull the pedestal out and clean it up or delete it!
Reply With Quote Quick reply to this message
  #5  
Old 12-02-2013, 06:43 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im gonna be upgrading in the summer. just trying to stick it untill then. Will it hurt anyting if i just turn the valve open? i assume from what i read that it is supposed to spring open when the regulator is unplugged. but im pretty sure its not open all the way and would this be related to something that controls the high idle?
Reply With Quote Quick reply to this message
  #6  
Old 12-02-2013, 06:45 PM
7.3 4 Ever! Nothing else!
 

Join Date: Aug 2012
Posts: 4,169
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by firefighter33 View Post
im gonna be upgrading in the summer. just trying to stick it untill then. Will it hurt anyting if i just turn the valve open? i assume from what i read that it is supposed to spring open when the regulator is unplugged. but im pretty sure its not open all the way and would this be related to something that controls the high idle?
if you keep it the way it is it will be sackless and you will loose MPG but you can pull it and clean it, throw it back in and G2G(good 2 go)
Reply With Quote Quick reply to this message
  #7  
Old 12-02-2013, 06:49 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah thats what its doing now. it has had bad mpgs and sluggish since i got it in february. maybe it has always been stuck and finally is starting to break free. i have no idea. that will be a week end project. but as far as the high idle problem any clue?
Reply With Quote Quick reply to this message
  #8  
Old 12-02-2013, 06:51 PM
7.3 4 Ever! Nothing else!
 

Join Date: Aug 2012
Posts: 4,169
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by firefighter33 View Post
yeah thats what its doing now. it has had bad mpgs and sluggish since i got it in february. maybe it has always been stuck and finally is starting to break free. i have no idea. that will be a week end project. but as far as the high idle problem any clue?
Yes if its stuck and clogged with chit then it wont cause the high idle to kick, once its cleaned up it should kick on start up!


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #9  
Old 12-02-2013, 06:58 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
that makes sense. ill have to give it a good cleaning see how it goes. thanks for the help i really appreciate it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:30 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors