E99 7.3 Fuel Pressure Issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-27-2013, 01:41 PM
Member
 

Join Date: Jul 2011
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
E99 7.3 Fuel Pressure Issues

Hey guys, I have tried everything I can think of and have had no luck. So the truck is a early 99 with a little under 180K, pretty much stock, just a intake and exhaust. It has all started back when I installed a chip from beans diesel back in July. Immediately after installing the chip I have had heavy smoke issues in every tune except the economy tune which still smokes a little. The truck gained power from the chip but it also brought out intermittent sluggishness which i realized i had always had but didn't really know anything different to notice it. Any way after trouble shooting with the chip company (which they 100% assure me it is not the tunes causing this) I installed a fuel pressure gauge pre filter and found that I had 50psi at idle and a 10-13 psi fuel drop at WOT, which is not right. So i have replaced the following things. New reman T500 HPOP, new bosch fuel pump on frame rail, I also replaced the Fuel Pressure Regulator on the fuel bowl and installed a stiffer spring which bumped the fuel pressure up to 70psi. I also pulled the bed off and did the Hutch/Harpoon mod with the kit from strictly diesel. I cleaned out the inside of the tank, found a little bit of debris but nothing major to clog up the pickup screens. So as it sits now the truck has 70psi of fuel pressure but still has the 10ish psi drop at WOT and still smokes a lot and has intermittent sluggishness ( its kinda of weird really, only lugs down and smokes when starting to go up a hill, it will smoke a lot then I have to floor it and eventually it down shifts and takes off. From a start it has all sorts of power smokes still but will light the tires up if I want to and has no sluggish issues. So whats left? Is there anything I can check in the fuel bowl that would cause the pressure drop besides the FPR? I have also heard injector orings can cause fuel pressure issues but I have 19k on new injectors so Im thinking its not that? Or the chip is actually messed up, I don't know. I can drive the truck normally no problem, starts up and runs great, Im just getting sick of smoking people out every time I go to go up a hill. Any suggestions? I was going to unplug the chip and see what the fuel pressure is but i dont see that helping the fuel pressure, but it will stop the smoke!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors