2001 Glow Plug Controller - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-18-2013, 07:03 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Alpine, Texas. For now
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to BentleyDrivesAFord
Question 2001 Glow Plug Controller

I am trying to locate where the Glow Plug Controller on my 01 7.3L F350. All I can find is a picture of it and a wire diagram NOT location, help please.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-18-2013, 07:36 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,618
Thanks: 0
Thanked 62 Times in 58 Posts
Feedback Score: 3 reviews
It's here...
Attached Thumbnails
2001 Glow Plug Controller-gp-aihrelays.jpg  
Reply With Quote Quick reply to this message
  #3  
Old 11-18-2013, 07:59 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Alpine, Texas. For now
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to BentleyDrivesAFord
*CONTROLLER* NOT RELAY. thanks anyway.
Reply With Quote Quick reply to this message
  #4  
Old 11-18-2013, 08:26 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,618
Thanks: 0
Thanked 62 Times in 58 Posts
Feedback Score: 3 reviews
WOW! For a New Guy you sure got Attitude

There IS no "controller" (other than the PCM). Is this a California truck you're talking about?
Reply With Quote Quick reply to this message
The Following User Says Thank You to NoRalPh For This Useful Post:
BentleyDrivesAFord (11-18-2013)
  #5  
Old 11-18-2013, 08:38 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Alpine, Texas. For now
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to BentleyDrivesAFord
Not sure. I bought the truck in Washington state. I does have the Ambulance package, 2 Alternators and PTO plate on the trans. I have changed all 8 glow plugs(what a *****) and the Relay. Both Delphi products. I am having an intermittent starting problem. It has been to 33deg here once since I changed them and it started no problem. At 40deg sometimes it just cranks, after 3 or 4 turns of the key(with out engaging the starter) the volt meter will finally show a draw. Then it will start normally. So it may be California truck. Not sure.
Reply With Quote Quick reply to this message
  #6  
Old 11-18-2013, 09:26 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: killen, alabama
Posts: 382
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
maybe a bad wire contact. i think there is a sensor for the temperature and that tells how long the glow plugs need to to heat. not 100% sure though.
Reply With Quote Quick reply to this message
  #7  
Old 11-18-2013, 10:06 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Alpine, Texas. For now
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to BentleyDrivesAFord
This is what I am looking for in my truck. Any one. *NoRalPh* I apologize for the attitude it was not my intent. Just frustration to the same answer I get. This is the Controller all have one in one form or another to control the relay.
Reply With Quote Quick reply to this message
  #8  
Old 11-18-2013, 11:46 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,618
Thanks: 0
Thanked 62 Times in 58 Posts
Feedback Score: 3 reviews
Quote:
Originally Posted by BentleyDrivesAFord View Post
This is what I am looking for in my truck. This is the Controller all have one in one form or another to control the relay.
Someone's given you some Bad info.... This controller, used on CA trucks, do NOT "have one in one form or another to control the relay" on ALL trucks. If you don't see that item, on top of the pass valvecover next to the relay, you Don't have one Anywhere else either (like the Vast majority of us).

If you have a Cold Start problem (and this is the time of year when we see Lots of complaints about it) go through this thread and figure-out what's wrong with the system.

Troubleshooting GPR & GP's
Reply With Quote Quick reply to this message
The Following User Says Thank You to NoRalPh For This Useful Post:
BentleyDrivesAFord (11-21-2013)
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors