02' 7.3 stalled at random? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-09-2013, 06:18 AM
Compression Ignition Addict
 

Join Date: Aug 2013
Posts: 301
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
02' 7.3 stalled at random?

So on my 10 minute commute to work yesterday I almost arrived, let off the gas and the truck instantly stalled. I stopped and thought I must have knocked my chip into anti theft. Nope.
Tried to start, truck hesitated then started. Ran for about 5 seconds and stalled again. This happen 3 times after I tried starting again. The. 4th time, it cranked up and drove away like nothing ever happened. Any clues?


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-10-2013, 04:45 PM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had the same thing happen to me today. Thought it was the fuel pump. Towed it home and started checking any fuel pump fuses but they were okay. I then tried starting it again and fired right up. Restarted truck 2 more times and no problem. Let it idle for 20 minutes and it didn't stall. Go figure!
Reply With Quote Quick reply to this message
  #3  
Old 11-10-2013, 04:57 PM
Chapter Director

 

Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,859
Thanks: 4
Thanked 40 Times in 35 Posts
Feedback Score: 5 reviews
Both of you guys replace your CPS with this Genuine Ford 7.3L Diesel Cam Position Sensor (CPS) - Blue then go from there. It sounds like your problems
Reply With Quote Quick reply to this message
  #4  
Old 11-10-2013, 06:29 PM
Compression Ignition Addict
 

Join Date: Aug 2013
Posts: 301
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Thanks! Will give it a shot. Happened again today
Reply With Quote Quick reply to this message
  #5  
Old 11-11-2013, 08:13 AM
Compression Ignition Addict
 

Join Date: Aug 2013
Posts: 301
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I actually just found one in my glovebox haha! Is this the same one? 02' 7.3 stalled at random?-imageuploadedbyautoguide1384190005.203853.jpg
Reply With Quote Quick reply to this message
  #6  
Old 11-11-2013, 08:16 AM
Chapter Director

 

Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,859
Thanks: 4
Thanked 40 Times in 35 Posts
Feedback Score: 5 reviews
Yes sir thats actually the original black CPS. Some guys say it was the best one of all the CPSs. Good find, but i gotta ask how dont you know whats in your glovebox???
Reply With Quote Quick reply to this message
  #7  
Old 11-11-2013, 08:30 AM
Compression Ignition Addict
 

Join Date: Aug 2013
Posts: 301
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
This was my brothers truck before it was mine. He has a whole bunch of **** in there haha!
Reply With Quote Quick reply to this message
  #8  
Old 11-11-2013, 08:33 AM
Chapter Director

 

Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,859
Thanks: 4
Thanked 40 Times in 35 Posts
Feedback Score: 5 reviews
Quote:
Originally Posted by BrodieBiking View Post
This was my brothers truck before it was mine. He has a whole bunch of **** in there haha!
Ahh i see, im too damn OCD whenever i get a new vehicle i have to completely empty it out and shampoo the crap outta everything so i can start from scratch and maybe find some buried treasures
Reply With Quote Quick reply to this message
  #9  
Old 11-11-2013, 08:39 AM
WNY Biodiesel Co-op
 

Join Date: Mar 2008
Location: Orchard Park New York
Posts: 870
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
After changing the CPS. If it stalls again ,try to start it , if it doesn't start, unplug the ICP, if it starts right up , you may have a bad ICP.
Reply With Quote Quick reply to this message
  #10  
Old 11-11-2013, 09:05 AM
Compression Ignition Addict
 

Join Date: Aug 2013
Posts: 301
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
What's weird to me is that when the truck dies, and I try to crank it back up,
its almost as it looses fuel pressure and it takes a few times to get it going again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:30 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors