2000 7.3 auto problems on highway, stopped for 1 minute now fine - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-06-2013, 05:05 AM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 7.3 auto problems on highway, stopped for 1 minute now fine

I bought a 2000 f250 7.3 about 7 months ago, been trouble free till this morning, going down the highway about 105 km, turbo boost normal at 6 or so psi, rpm around 2000 all of a sudden noticed a chirping not too loud but loud enough I could hear it over the truck. Dramatic loss of speed and power and rpm through the roof, motor started vibrating. Pulled over to see what was up when I slowed down the vibration went away and the chirping seemed to go away, oil level was fine and I only had about 5 minutes remaining, so I went on trouble free, I don't want to ignore it and have it leaving me stranded, the truck has 413xxx kms on it and I don't know what the previous owner did or didn't do... Any help is greatly appreciated!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-06-2013, 05:07 AM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ps

I should add that I was stopped for about 3 minutes...
Reply With Quote Quick reply to this message
  #3  
Old 11-27-2013, 05:03 AM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Figured maybe the uvch's we're coming apart, so I changed those as well as the glow plugs while I was in there, as well as a new fuel filter, took it for a test drive and about ten minutes down the road it started missing and running rough again, brought it back and went and talked to a ford mechanic, he suggested changing the fuel pump since it was original and had 400kms on it, changed the fuel pump starts way easier now, bout 20 minutes this time and did the same loss of power running rough as before, dropped the truck off at the dealer they scanned it and checked every damn thing on the motor with it turning up fine, I asked about the in tank filters they said it for sure wouldn't be that, so I brought the truck home and pulled the tank, the filters in the tank were plugged solid. 4 can of brake clean later, problem solved.
Attached Thumbnails
2000 7.3 auto problems on highway, stopped for 1 minute now fine-image.jpg  
Reply With Quote Quick reply to this message
  #4  
Old 11-27-2013, 08:28 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Location: Sunny of Louisville, KY
Posts: 17
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Good to know if I ever start having the same problem.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
turbo 7.3 powerstoke?

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors