2003 7.3 HELP!!!! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-26-2013, 07:41 PM Thread Starter
Member
 
niterunnr's Avatar
 
Join Date: Mar 2010
Location: Mustang Oklahoma
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 7.3 HELP!!!!

I have a 2003 7.3 diesel. truck has 230xxx miles. Motor I am not sure. It had a new long block put in about 6 months ago. It was dying and would not start for at least 10 minutes. I replaced the cam sensor. Noticed the icp sensor had oil in the plug so I replaced both and wired back with heat shrink connectors. Now in throttle going down the highway it coughs and will throw a little white smoke. If sitting at an idle or not in the throttle it dies. It will start right back up. It finally threw the check engine light. I got home and threw it on the scanner but the light had reset itself and my scanner showed no codes. Any ideas where to go next? It also has a small amount on oil accruing on top of the intake.. Thanks in advance for any advice. I traded my perfectly fine mustang gt for this new toy and im really starting to think I got in over my head......
niterunnr is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-26-2013, 11:26 PM
Powerstroke.org Sponsor

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 8,354
Mentioned: 45 Post(s)
Tagged: 0 Thread(s)
Quoted: 152 Post(s)
Thanks: 685
Thanked 409 Times in 374 Posts
Feedback Score: 1 reviews
Could be lots of things, but I think I would start with fuel filter. A leak in your HPOP system.

Sent from AutoGuide.com Free App

E99CCLB 250/200s,STG1cam, KC38R, 4" exh,CNC FAB fuel&oil lines,140vIDM,BTS,S&B

97 ECLB F250 4x4 all stock
96 CCLB F350 4x4 D60 swap stock



EDGE,S&B,SCT,PHP Hydra,TS-Perf,OEM parts,Sam Wyse trans,VB's,LED's,MBRP,ISSPRO,ICON,FOX,KC TURBOs,SD 7.3 fuel kits, HPOP lines

www.cncfabricationllc.com or email sales@cncfabricationllc.com

Corey@CNCFAB is online now  
post #3 of 3 Old 12-20-2013, 11:39 PM Thread Starter
Member
 
niterunnr's Avatar
 
Join Date: Mar 2010
Location: Mustang Oklahoma
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ipr valve fixed the problem
niterunnr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome