1999 7.3 Rough Idle and Check Engine Light Problem - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 11-01-2006, 05:00 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
1999 7.3 Rough Idle and Check Engine Light Problem

i have a 1999 F350 7.3L powerstroke and it is giving me a rough idling problem. When I go to start it up it seems to struggle a bit getting started then it will idle rough and slow. The check engine light comes on but sometimes when I get up to highway speeds it seems to run a little smoother and the light will sometimes go off for a few seconds but never stays off. I've changed the oil, fuel filter, and air filter recently and even checked the intercooler pipes to see if any of them were loose but they all seem to be fine. What do I need to get to check the codes for the check engine light? If anyone has any idea whats goin on i'd appreciate the info, thanks.
nimmo is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 11-01-2006, 06:01 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 5 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I would pull your valve covers and see if the connector on the inside of the vavle cover is coming disconnected...i would say there is an 80% chance that this is your problem
mschn99 is offline  
post #3 of 12 Old 11-01-2006, 09:04 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
thanks marc, i'll check it out tomorrow.
nimmo is offline  
post #4 of 12 Old 03-09-2009, 07:05 PM
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by nimmo View Post
i have a 1999 F350 7.3L powerstroke and it is giving me a rough idling problem. When I go to start it up it seems to struggle a bit getting started then it will idle rough and slow. The check engine light comes on but sometimes when I get up to highway speeds it seems to run a little smoother and the light will sometimes go off for a few seconds but never stays off. I've changed the oil, fuel filter, and air filter recently and even checked the intercooler pipes to see if any of them were loose but they all seem to be fine. What do I need to get to check the codes for the check engine light? If anyone has any idea whats goin on i'd appreciate the info, thanks.
can anyone help me? I have the same problem.
timkickler is offline  
post #5 of 12 Old 03-09-2009, 07:11 PM
Compression Ignition Addict
 
b.edens's Avatar
 
Join Date: Feb 2009
Location: Big Spring Texas
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to b.edens
Mine was about a 1/4 spoon worth of sand got in my system

1997 F-250 4X4
Crewcab short bed
Ranchhand front and rear replacement
460 cu. in.
Bored .060 over
JE Pistons
Forged Conn. rods
Forged Crank
Thin Headgaskets
Stainless Steel Valves
Heads Ported And Polished
Custom Comp Cams Grind
Previous owner said Dyno was 551.6 on the ground in 2wd'
Gets 8 MPG max
38 gallon rear replacement tank form LMC
AND ..... MORE



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
b.edens is offline  
post #6 of 12 Old 03-09-2009, 07:13 PM
Compression Ignition Addict
 
sldghamr's Avatar
 
Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i had a similar problem with my 7.3L, ended up being the IDM was dying.

if you see a light at the end of the tunnel, it's probably just a photon torpedo
sldghamr is offline  
post #7 of 12 Old 03-09-2009, 08:34 PM
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by sldghamr View Post
i had a similar problem with my 7.3L, ended up being the IDM was dying.

Stupid question... Whats the IDM?
timkickler is offline  
post #8 of 12 Old 03-09-2009, 08:36 PM
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by b.edens View Post
Mine was about a 1/4 spoon worth of sand got in my system

SAND? GOT IN WHERE. I SUPPOSE I GOT DIRT......
timkickler is offline  
post #9 of 12 Old 03-09-2009, 08:36 PM
Compression Ignition Addict
 
b.edens's Avatar
 
Join Date: Feb 2009
Location: Big Spring Texas
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to b.edens
hah i asked that last week its the injector driver module it is in the drivers side fender well behind the plastic towards the cab and up

1997 F-250 4X4
Crewcab short bed
Ranchhand front and rear replacement
460 cu. in.
Bored .060 over
JE Pistons
Forged Conn. rods
Forged Crank
Thin Headgaskets
Stainless Steel Valves
Heads Ported And Polished
Custom Comp Cams Grind
Previous owner said Dyno was 551.6 on the ground in 2wd'
Gets 8 MPG max
38 gallon rear replacement tank form LMC
AND ..... MORE



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
b.edens is offline  
post #10 of 12 Old 03-09-2009, 08:37 PM
Compression Ignition Addict
 
b.edens's Avatar
 
Join Date: Feb 2009
Location: Big Spring Texas
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to b.edens
yeah evidently a cab n chassis with the FILLER HOSE OFF and an idiot guy i bought it from with no FILTER IN IT

1997 F-250 4X4
Crewcab short bed
Ranchhand front and rear replacement
460 cu. in.
Bored .060 over
JE Pistons
Forged Conn. rods
Forged Crank
Thin Headgaskets
Stainless Steel Valves
Heads Ported And Polished
Custom Comp Cams Grind
Previous owner said Dyno was 551.6 on the ground in 2wd'
Gets 8 MPG max
38 gallon rear replacement tank form LMC
AND ..... MORE



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
b.edens is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome