99 powerstroke glow plug relay problem - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-09-2013, 06:20 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Cool 99 powerstroke glow plug relay problem

Truck is getting harder and harder to start and thought it might be the glow plug relay. I checked it with a volt meter and it has voltage across it but the relay is making a loud ticking noise that i have never heard it make before. Is the relay shorting out? Or what else could cause this?
banditman is offline  
post #2 of 2 Old 10-09-2013, 08:18 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
switch to synthetic. If yuo got both a relay for the gp and aih, swap them relays (same unit), and see what happens. My gpr went south so now, everything get'n powered by my aih relay.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome