Engine light flash? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-29-2006, 01:57 PM
Member
 

Join Date: Sep 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Engine light flash?

I have noticed this for about 2-3 years no but I haven't really thought about it........untill lately.......

About 2 weeks ago I used my 99 F-250 to haul 2 vehicles on a 37 foot gooseneck trailer.... It was about 18,500 LBS! The most I have ever hauled!! I was suprised at how AWESOME my truck did!! sure I slowed down to about 40mph on the steep hills but that was about it!! I was sure to go real easy on it I never had it floored the hole trip.

My question is this.......when going up steep hills or under heavy acelleration the check engin light would flash really quick......It never would do it when i wanted it to so i have no idea what sets it off.........I just know it did it more on this trip then it has ever done it before.

I have a HyperTech Power Programmer III my exhaust is straight piped with no cat or muffler that is about all the upgrades i have done.

any ideas what makes that thing flash while towing?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-29-2006, 02:04 PM
Premium Member
 

Join Date: Jan 2006
Location: florida
Posts: 1,893
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you should be able to get a code, the pcm should store it for a while.
Reply With Quote Quick reply to this message
  #3  
Old 10-29-2006, 06:21 PM
Member
 

Join Date: Sep 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I thought the light had to be on continuous for you to get a code?
Reply With Quote Quick reply to this message
  #4  
Old 10-29-2006, 06:29 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
It might have been a warning about something when you were pulling. Do you have guages?
Reply With Quote Quick reply to this message
  #5  
Old 10-29-2006, 06:37 PM
Member
 

Join Date: Sep 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No i don't have any gauges............I need to get some BAD! It has done this for as long as i have had the programmer. Doesn't matter if I tow 4000 or 19000 it just seemed to do it more when I was pulling heavier weight. I am pretty sure my EGT's were OK cause I wasn't pushing it that hard and it was pretty cold. I have no idea on how much boost I get......

Last time i had the emissions done the dyno read 660 rear wheel torque and 220 HP so I have no idea if that helps at all.......
Reply With Quote Quick reply to this message
  #6  
Old 10-29-2006, 06:57 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
It may have something to do with temps getting too high. With a tuner, your temps can really jump up. Maybe what it is, but I would check your codes and see what they say.

On a side note, can you put your info in and where you are from, that way it will answer some questions in the future. easier to help ya out. thanks and hope you figure it out. Might want to check the owners manual too.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:40 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors