Poor mpg loss of power - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-29-2013, 11:40 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Poor mpg loss of power

It's a 01 f350 dually 4x4 stock motor straight piped I think I'm getting around 9mpg It has a loss of power feels like it might be a boos problem not really sure I also think injector number 8 is going bad it's kind of rough to start and oil change and fuel filter are up to Date I'm not sure what else it could be if you guy could help that would be awesome Thanks
Kmagro90 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-30-2013, 08:39 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
clean the EBP tube/sensor. Go to guzzlediesel website. Make a boost leaker tester, ohm out injectors and gp's at the uvch.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome