Burning smell at startup - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-25-2013, 04:26 AM Thread Starter
Powerstroke.org Fanatic
Join Date: Aug 2009
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Burning smell at startup

I am getting a burning smell (burnt rubber, sometimes a little electrical) only when I start the truck. Its worse if I have the a/c or fan running, if I have toes off I get no smell. I already replaced the starter and inspected those lines, but other thanh that there are no obvious suspects. Ideas? It's an 01 excursion, chipped, bb turbo 151k. Thanks
macsdaddy is offline  
Sponsored Links
post #2 of 2 Old 09-25-2013, 05:57 AM
Serving Our Country!
JSchuricht's Avatar
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,961
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 23 Times in 22 Posts
Feedback Score: 2 reviews
Check your belt. Better yet, pull the belt and check everything that should rotate freely.

JSchuricht is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome