2001 7.3 (ICP?) Issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-14-2013, 04:17 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Location: McGuire AFB, NJ
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2001 7.3 (ICP?) Issues

Long time lurker and first time poster. I bought a 2001 F350 7.3 Powerstroke 4x4 Crew Cab Short Bed a couple months ago. I just recently got stationed in New Jersey, and am new to the east coast. So the truck ran fine, the only problem I had with it when I bought it was the oil pan, it is rusted in the sump, and oil is seeping through the bottom (Approx. 3-4 Drips per minute), which I figured I could fix, as I am a heavy diesel mechanic in the Air Force. I didnt know at the time that I needed to pull the entire engine to do that. Anyway, thats not my issue. About a month ago, I did an oil change, after the oil change, is when my issues started, rough idle, "hiccups" while driving at cruising speed, and finally it died on me once at a stop light, but then started right back up, and ran fine for the rest of the trip home. Thought it could be the CPS, so I replaced that, and that didn't solve the problem, so I looked next at the ICP, I unplugged it, it was filled with oil, and it smoothed out when it was unplugged, so I figured that was bad as well, so I replaced it. Once I got the new ICP in, I plugged it in, and STILL rough idle and "hiccuping" at cruising. My next venture will probably be cleaning the IPR and the EBPS and tube. I was wondering if anyone had a similar problem or could shed some light on some things I could look into. I do not have access to any sort of scanner other than my OBDII scanner from Harbor Freight. I have the ICP unplugged still, and continue to drive it and it runs pretty good, seems low on power and slightly rough idle, but nothing too bad. I've got a baby on the way and wanting to get this problem figured out. Thanks for all the help in advance.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-14-2013, 06:36 AM
Compression Ignition Addict
 

Join Date: Aug 2010
Posts: 1,764
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
your on the right track, bud. I think the EBP sensor and tube need attending/replaced, along with a IPR replacement. Not a fan of "rebuilding" them. Heck, the oem lasted 13yrs, why not replace with oem new...
Reply With Quote Quick reply to this message
  #3  
Old 09-29-2013, 01:21 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Location: McGuire AFB, NJ
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bump... Anyone else have any more ideas? I replaced the fuel filter today, and running diesel kleen through this tank. Still running with the ICP unplugged, and would love to have a fix.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
cps, icp sensor, ipr, rough idle

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors