poor running 7.3 - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-01-2013, 07:40 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2012
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
poor running 7.3

So last week as I'm getting up to freeway speeds the truck starts acting like it is got a bad mis. I have the local ford dealer run a diagnostic test and they say the #2 injector is dead, the #3 injector is weak and a possible injector module controller being bad.

So I open both valve covers and do the 25cent fix. Didn't fix it. I replace the #2 injector, didn't fix it. Could the weak injector be causing the problem to continue or is it the module.
workin it is offline  
post #2 of 4 Old 09-01-2013, 07:57 AM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
If your under valve cover harnesses and pigtails connectors are good, and oil is fresh, I would change camshaft position sensor first, then possibly look at the InjectorDriverModule.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #3 of 4 Old 09-01-2013, 08:09 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2012
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
poor running 7.3

Thanks, should I change the #3 injector or is this a case of something else is making the injector weak.
workin it is offline  
post #4 of 4 Old 09-01-2013, 08:40 AM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
I don't think it's the injectors. I'd run a buzz test and cylinder contribution test anyway.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome