7.3 idles rough - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-19-2013, 08:00 AM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 idles rough

Im having with my 03, 7.3. Its hard to start and when it starts , it idles rough. When i try to take off, it cuts off or i have to pat the gas to keep it running. When it does run, it idles rough and then all of a sutton, it takes off. It almost seems like it gets to much diesel. I have replaced 5 injecters and all o-rings, a new computer board. NEED HELP. Spending money with no results.

Someone said that it might be the cam sensor or fuel pressure

Last edited by stsmith; 08-20-2013 at 03:30 AM.
stsmith is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome