02 E-450 heavy blue smoke when cold - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-23-2013, 07:44 AM Thread Starter
Powerstroke.org Rookie
1stgenstroker's Avatar
Join Date: Nov 2008
Location: Johnstown, PA
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
02 E-450 heavy blue smoke when cold

Hi all! Haven't been on for a while. I work as an EMT and need some input. Service is looking to buy an 02 E-450 7.3 Powerstroke 4x2 ambulance with 96k. Truck starts fine but has hesitation (feels like you are dragging a mountain behind you) and heavy blue smoke when you apply the throttle. This lasts until truck gets to operating temp. As the truck warms up the smoke lessens and then goes away completely. The truck runs great once it warms up. The current temps here in my part of PA have been 60s overnight and 70s-80s during the day. All symptoms are same if truck sits 1 day or 1 week. Ford garage did diagnostic and said turbo is weak and maxing out at 8psi when it should be 12psi. Does this sound right? Or do symptoms sound more like bad injector(s)? I've never heard of a turbo being weak but truck runs great when warm
1stgenstroker is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome