voltage problems - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-15-2013, 06:10 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Location: Dark side of the moon
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
voltage problems

Hey everyone Im having trouble with my truck for a while now. It started when my battery light went on and i got the alternator tested Advance and Auto Zone both said the alternator was bad. I ended up getting a replacement at Pepboys since they were the only ones that it in stock. After I replaced the alternator, the battery light was still on. I had Napa batteries in it from the previous owner and went through them to get 2 replacement ones. After I installed them the light was still on. But the truck drove fine for about 2 weeks. Now the truck will only start when its jumped and after driving on the highway for a half hour the voltage on the batteries is 10.4v. I went back and had the new alternator tested and it passed.... Does anyone have any idea of what the underlying problem could be?

2003 f-350 7.3
2011 bed
Tymar intake
MBRP 4 inch
Rouge601 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-15-2013, 06:18 PM
Premium Member
 
Join Date: Apr 2011
Location: Baton Rouge
Posts: 1,127
Thanks: 2
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
You need batteries. A buddy of mine had the same issue with cheap batteries. They were "rated" correctly, but didn't have the azz that they claimed to have.
Moto2four is offline  
post #3 of 4 Old 07-16-2013, 05:32 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Location: Dark side of the moon
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So Napa Brand batteries is not good then? What do you recommend for a replacement?

2003 f-350 7.3
2011 bed
Tymar intake
MBRP 4 inch
Rouge601 is offline  
post #4 of 4 Old 07-16-2013, 07:35 AM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
my COSTCO/Kirkland batteries are doing the job. Get the biggest/cca batteries you can find for the application.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome