Need some help folks. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-12-2013, 11:25 AM Thread Starter Rookie
Join Date: Jun 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need some help folks.

2001 f-350 7.3.Sorry for long post. I really need some help. Started running sluggish, couldn't hardly pass a car. picked up camper and it wouldn't pull at all. Changed out filter and tried again, still wouldn't pull. Next morning I drained the tank thinking bad fuel and added seafoam conditioner. Tried to pull again and worked fine until exhaust temp got to 650. Started missing and running on what seemed like 4 cyls. Unhooked camper and ran the truck to get a new fuel pump. Ran fine and tested ok. Put camper on it again and same trouble. When the temp gets to 600-700 it starts having a fit. Brought to shop and they ran a scan and it showed no codes until I took a test ride with computer hooked up and the #3 injector showed a failure. Changed out, no help. Scaned again and showed fuel sensor bad changed it out, no help. Does anyone have any ideas?
KPM1115 is offline  
Sponsored Links
post #2 of 2 Old 06-13-2013, 09:35 AM
Compression Ignition Addict
timmyboy76's Avatar
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
I'd start with the easy stuff...


50 cent mod.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome