HELP!!!! My 1997 F250 Just died going down the road!! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 06-06-2013, 03:32 PM Thread Starter
Compression Ignition Addict
 
jimhuntertx's Avatar
 
Join Date: May 2013
Location: Austin
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Skype™ to jimhuntertx
Exclamation HELP!!!! My 1997 F250 Just died going down the road!!

I was driving down the road when she just died. No warning no smoke or anything, no over heating, oil pressure was good. I pulled over waited a min then she refired and died. I started her up again got home about a mile away. Got it in the driveway and now after checking the fuel filter, looks black but not full of grit or anything obvious. Now she won't start. I crank and crank, the oil pressure gauge stays down then suddenly goes to the middle of the gauge. I checked the dipstick and it looks like she might be a little low but there are no puddles or smoke anywhere. Can it be being a little low on oil cause the no run situation. What else could it be? CPS, FPR, HPOP? Please help me I can't afford to take her to the shop to get it fixed. Im fairly mechanical but this is my first diesel so I'm flying blind here. Again any help is greatly appreciated.

Jim


97 F-250 2wd Extended Cab Longbox, Pyro,boost and trans temp guage, 3" down pipe,
New E4OD Trans, TS 6 chip
Banks TransComander, 4" to dual 4" Bullydog 4" Dual Exahust , DIY Tymar intake w/ K&N Filter, Shimmed FPR

jimhuntertx is offline  
post #2 of 8 Old 06-06-2013, 03:51 PM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,194
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 7
Thanked 232 Times in 223 Posts
Feedback Score: 3 reviews
CPS would be the likely place to start. You should always carry a spare anyway, so if you bought one and it didn't fix it you'd have your spare at least
NoRalPh is offline  
post #3 of 8 Old 06-06-2013, 03:52 PM Thread Starter
Compression Ignition Addict
 
jimhuntertx's Avatar
 
Join Date: May 2013
Location: Austin
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Skype™ to jimhuntertx
I hate to sound stupid but

Where is it located? front of the motor on the passenger side right?

Jim

97 F-250 2wd Extended Cab Longbox, Pyro,boost and trans temp guage, 3" down pipe,
New E4OD Trans, TS 6 chip
Banks TransComander, 4" to dual 4" Bullydog 4" Dual Exahust , DIY Tymar intake w/ K&N Filter, Shimmed FPR

jimhuntertx is offline  
post #4 of 8 Old 06-08-2013, 04:36 AM
Premium Member
 
Join Date: Jul 2012
Posts: 346
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by jimhuntertx View Post
Where is it located? front of the motor on the passenger side right?

Jim
yes. about 11 o'clock if you were looking at harmonic balancer
barrakudaman is offline  
post #5 of 8 Old 06-25-2013, 03:40 PM
Member
 
Join Date: Nov 2009
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any update? Mine is at the point to where it will randomly stall at stop signs and even in the middle of a turn. Did it 3 times on the way home last night. Its an early 99 F350 SRW with 182,000 miles and original CPS.
None2Slow is offline  
post #6 of 8 Old 06-25-2013, 03:45 PM Thread Starter
Compression Ignition Addict
 
jimhuntertx's Avatar
 
Join Date: May 2013
Location: Austin
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Skype™ to jimhuntertx
Yes, The shop I took the truck to replaced the CPS with a factory ford one and fixed the problem. They also went through the whole truck to make sure there was nothing else wrong.

So if you are running on the original CPS in your truck I would get another one from Ford and put it in there. It should fix the problem.

Jim

97 F-250 2wd Extended Cab Longbox, Pyro,boost and trans temp guage, 3" down pipe,
New E4OD Trans, TS 6 chip
Banks TransComander, 4" to dual 4" Bullydog 4" Dual Exahust , DIY Tymar intake w/ K&N Filter, Shimmed FPR

jimhuntertx is offline  
post #7 of 8 Old 06-25-2013, 03:52 PM
Member
 
Join Date: Nov 2009
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the update, I'll get right on it.
None2Slow is offline  
post #8 of 8 Old 11-19-2013, 09:23 PM
Member
 
Join Date: Nov 2009
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just an update to the update, I replaced the CPS and all is well with the world now.
None2Slow is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome