Code p1211 help?? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-29-2013, 11:50 AM Thread Starter Fanatic
Join Date: Mar 2010
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Code p1211 help??

I Have a 99 350sd 7.3 with 558,000 on it. It was running weak ad surging while loaded. I replaced 6 injectors supply pump filter, it ran better but still surged under load. I had "good" looked almost new hpop and ipr. I replaced the irp and my truck ran good for about 15,000 miles. Now it's started coding P1211 inj. pres. higher or lower than desired. When I came to and idle after driving a short distance the motor had a "Roll" to it. i cut ingnition off and restarted it and ran ok till it started to act up agian. The inj pressure was running 750-925 psi and the pres. percent was like 5% normally it runs about 490-525 at idle with 9-12% and when running under load the percent was 35-65%. Any ideas? I replaced the ICP sensor about a year ago also. soemtimes it runs ok nbut has been getting frequent on acting up.
Wonder could this "new" IPR be sticking or something? I had it on my shelf for a few years but looks like new when I put it in?
mcgoo422000 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome