ICP Question - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2013, 06:27 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ICP Question

My Excursion has been have an erratic idle when I am stopped and engine is warm. Feels like my whole cab is shaking. But it doesn't sound like it's going to die or anything...just shakes. Changed the UVCH and connector was loose, but it still ran the same. Tonight I unplugged the ICP sensor and it seemed to smooth out quite a bit. My question is, can I run it all day tomorrow with it unplugged to see if it runs smooth all day? Don't want it to stall or cause more problems. Thanks.

Last edited by chugluglug; 05-09-2013 at 07:57 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-09-2013, 07:26 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2013
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You can run without it connected people do it al of the time. The PCM will go into limp mode and performance and milage may suffer. Was there oil in the ICP sensor connector?
Reply With Quote Quick reply to this message
  #3  
Old 05-09-2013, 07:30 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did notice a loss of power, and yes there was oil in it.
Reply With Quote Quick reply to this message
  #4  
Old 05-09-2013, 07:47 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2013
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I think, you sir, have found your problem. Get your ICP sensor fron tousley ford parts. Call and ask for Mark he will treat you right. Tell him Jake told you to call. They ship fast and are going to be the cheapest route. Don't buy this sensor from anywhere but a Ford or International dealer.
Reply With Quote Quick reply to this message
  #5  
Old 05-09-2013, 07:51 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Jake!
Reply With Quote Quick reply to this message
  #6  
Old 05-09-2013, 08:12 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2013
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's my pleasure to help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:22 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors