Low on power...poor mileage!!!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-24-2008, 03:20 PM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Low on power...poor mileage!!!!!

Hi guys, new to the site... I have a 2000 F-350 with a 6spd. The problem is that it just doesn't have the power it use to have. I did the turbo about 3000 miles ago and it helped but it isn't what it used to be. It has a good fuel filter and air filter. Back when it was good it would reach full boost(17psi) around 1900 rpm's and hold good until I shifted. Now, I have to pull to about 2250 rpm's before I see 17psi. Also the fuel mileage has gone down noticably. I am wondering if it is a fuel pressure(pump) issue. Any input on the matter would be a great help.

Is there are good resource available for troubleshooting help...where to check fuel pressures and so on.

The truck is stock except for exhaust...no chip/programmer.

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-24-2008, 04:29 PM
Member
 

Join Date: Jan 2008
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
YOU SHOULD BE GETTIN BETTER BOOST THAN THAT. MY 96' OBS WITH EDGE EVO AND BALDWIN INTAKE GET 15-16 PSI AT 550 RPM AND GETTIN 26-30 PSI AS THE RPM BUILDS AND SHE HAS 177K ON HER WITH FRESH TRANNY. 4" EXHAUST IS COMIN THIS WEEK.
Reply With Quote Quick reply to this message
  #3  
Old 02-24-2008, 05:19 PM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It has always maxed out at 17psi. Even when it had good power it would max at 17 psi. I have had a boost gauge on it since about 30k miles and that is what it has always read. It has about 110k on it now.. Thanks for the reply....You are going to like that exhaust.
Reply With Quote Quick reply to this message
  #4  
Old 02-24-2008, 07:04 PM
Member
 

Join Date: Sep 2006
Location: central coast side CA
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ha check this web site out it say a similar problem and how they fix it
for power loss and milage loss
Welcome to guzzle's Exhaust Backpressure Sensor Cleaning Maintenance Web Page
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors