Wrong Oil - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-23-2008, 04:36 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2007
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wrong Oil

So... I took my truck in for an oil change midway through a long haul (2800 miles).

So about 800 miles later the truck starts lacking power, sounds almost like something is snapping under the hood... or almost like there's a leak in the manifold really close to the exhaust valve. By that I mean whenever it loses power, it goes "snap, snap, snap, snap..." almost like a gasser with a cracked coilpack that's arcing to something metal.

Shut it down, let it cool off, started back up and it drove fine the rest of the trip.

Now this problem resurfaces randomly only when the truck is warm.

Check the receipt, they put in 15W50 Mobil 1. Had the oil changed to Rotella 15W40, but the problem still occurs.

Any ideas?

Did something get damaged from the Mobil 1 which is only CF rated? Or is this unrelated?

Thanks in advance,


Last edited by mwallans; 02-24-2008 at 09:44 AM.
mwallans is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome