2000 f350 7.3 hard start when cold - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-20-2008, 05:17 AM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 f350 7.3 hard start when cold

ok last time this was the case two yrs ago i put in a new glow plug rely... It cured it... i put one in last week seemed better but not great.... not the other relay in the front of the glow plug one is what? another relay or a intake heater.. could this be shot too or? hmmm was 20 and wasnt plugged in... I have gel additive in the fuel all the time what else truck only has 80 k
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors