It's Finally Fixed - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-23-2013, 01:04 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's Finally Fixed

I just wanted to update everyone on my truck and let you know that I have finally fixed it. Hopefully I can help someone else out who is experiencing the same issues I was. Just a quick overview of the truck I have owned the thing for almost 3 years and since I have owned it I have always had to plug it in for it to start in the morning no matter the temperature. Well that problem is no more. Thanks to Swamps and 8 new injectors my truck starts and runs flawless I couldnít be happier with my truck. I would also recommend Swamps Diesel to anyone!! Top notch service and products.

Hereís a link to a previous post of where I was at before ordering my injectors.

Compression Test and Injectors

Hereís also a link to a video of me starting it with the old injectors and being plugged in for about 12 hours(notice Temp gauge).

IMG_1202.mp4 Video by volvohotroder | Photobucket

And here is how it starts now. It was 37 degrees this morning not plugged in.

IMG_1239.mp4 Video by volvohotroder | Photobucket

I hope this can be helpful to anyone out there. Please donít hesitate to ask questions id be more than happy to answer.

Thanks,

Evan
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-23-2013, 01:55 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
at my wits end

Just wondering if you found oil in your intake tube near your turbo before you changed injectors and also was your truck blowing black or blue smoke when you would punch-it before? sounds a lot like problems i'm having with my bone stock 03 7.3. mine does puff white smoke when I start it and i've checked or replaced same things you talked about except injectors. no oil in fuel bowl either, so leaning against just o-rings or cups. also wondering if you did a buzz test on injectors before. sorry to ask so much, just at my wits end. Thank you for all the info you posted. really sounds like injectors for me too. what do you think?

Thank You,

Aaron
Reply With Quote Quick reply to this message
  #3  
Old 04-23-2013, 02:07 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Aaron I usually always have a little oil in my intake tube before the turbo. I believe this is because the crankcase vent on top of the valve cover is vented into it. My truck would blow black smoke when I was switched into my 140 hp tune but never had blue smoke. My orings were in good condition it was the internal mechanical parts of my injectors that were gone. I did multiple buzz test and injectors were shown as ok each time. The way I finally determined it was by pulling the valve covers and starting the engine. While the engine was running I noticed i had only 1 injector pumping oil from the deflector until it got warmer than the other injectors would start pumping as well. After it ran for 15 minutes I unplugged the electrical connector from each injector 1 by 1 to see if it made the truck run any worse or if it made no difference. I had 4 injectors with bad electronics. Hopefully this answers your questions or gives you any other things to check.
Reply With Quote Quick reply to this message
  #4  
Old 04-23-2013, 06:41 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks

thanks. removing valve covers this weekend. sounds like you got me on the right track. I realy appreciate it. I'll let you know how it goes. thanks again.

Aaron
Reply With Quote Quick reply to this message
  #5  
Old 04-25-2013, 03:22 AM
Member
 

Join Date: Nov 2008
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Evan -

Just wondering - have you noticed any difference in engine noise with the new injectors? I watched the videos but couldn't get a sense of engine noise from the vids - I thought that maybe it was quieter with the new injectors but I'm not sure.

Thanks,

Moe
Reply With Quote Quick reply to this message
  #6  
Old 04-25-2013, 02:37 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Moe you are correct! It is extremely quieter then it used to be no more knock sound coming from the old wore out injectors! Makes driving down the road and having a conversation enjoyable now.
Reply With Quote Quick reply to this message
  #7  
Old 04-25-2013, 03:00 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Posts: 1,696
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
cool beans, red Whats all been done to ur truck and what injectors you went with?
Reply With Quote Quick reply to this message
  #8  
Old 04-25-2013, 05:22 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Timmyboy! My mods are in my SIG. I just went with factory remans im wishing i would have jumped up to stage 1's now but im happy with it the way it is. It runs better now then it ever has before in the time ive owned it.
Reply With Quote Quick reply to this message
  #9  
Old 04-25-2013, 05:41 PM
Member
 

Join Date: Nov 2008
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok, thanks for that reply Evan. I bought this truck with over 200k on it - although it runs fine, the noise is unbearable. I've tried a few things to quiet it but no dice. I do think it's all injector noise. I guess I'm due for injectors.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors